Find the answer to your Linux question:
Results 1 to 4 of 4
I'm trying to set up my arch laptops wireless card to work at my school. Wireless works fine at my place (doesnt use a key) but doesnt work at my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392

    Howto set WEP in conf.d/wireless?


    I'm trying to set up my arch laptops wireless card to work at my school. Wireless works fine at my place (doesnt use a key) but doesnt work at my school (has a key.)
    I have my settings in /etc/conf.d/wireless, and i followed this guide from wiki.archlinux.org

    This is my /etc/conf.d/wireless:
    # Settings for wireless cards

    Code:
    #HOME WIRELESS
    #wlan_eth1="eth1 essid HomEssid"
    
    #APT WIRELESS
    #wlan_eth1="eth1 essid AptEssid"
    
    #SCHOOL WIRELESS
    wlan_eth1="eth1 essid SchoolEssid"
    wlan_eth1="eth1 essid SchoolEssid key School10digitWEP"
    #wlan_eth1="eth1 essid SchoolEssid key s:(nothing)"
    This is how it looks when I try to start the connection at school. The way it's set up, is I should first be able to get "limited connectivity," but still be able to access "https://connect.MySchool.edu" to register. After registering I should have full connectivity. The problem is, after enabling eth1 using 'dhcpcd eth1', I still cannot connect to register. The IT staff doesnt know where to start with linux.
    Anyone have any ideas where I'm going wrong? Help would be greatly appreciated.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    when you run dhcpcd eth1 you get connected without any errors?

    can you ping your school.

    So for instance I went to bc and I could ping www.bc.edu before the registration stuff.


    if the dhcpcd is conncecting that this has nothing to do with your WEP key because it wouldn't connect at all with wrong key.

    for some possible options with dhcpcd look at the man page. Sometimes you just need to screw around a little bit to get it to work.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Yea it never supplies me with any errors. I'll
    dhcpcd -d eth1
    next time to see what kind of output its giving.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User ImNeat's Avatar
    Join Date
    Feb 2006
    Location
    N. America
    Posts
    392
    Solved. Just had to change the format: 12:34:56:78:90.
    10" Sony Vaio SRX99P 850MHz P3-M 256MB RAM 20GB HD : ArchLinux
    14" Dell Inspiron 1420N 2GHz Core2Duo 2GB RAM 160GB HD : Xubuntu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •