Find the answer to your Linux question:
Results 1 to 5 of 5
I have a compaq presario 2100 and the conexant aclink modem does not work in linux. using kppp i can connect but it disconnects every few seconds/minutes. With Kinternet its ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2005
    Location
    Lahore, Pakistan
    Posts
    163

    KInternet


    I have a compaq presario 2100 and the conexant aclink modem does not work in linux. using kppp i can connect but it disconnects every few seconds/minutes. With Kinternet its says waiting for carrier NO CARRIER exit status 17. is there anyone who can please help resolve this issue.

    Thanks
    Registered Linux User #395492
    My blog: http://www.khooban.com/nucleus/?&blogid=2
    Desktop (Cassius) Pentium 4 1.5Ghz, 512MB SDRAM, 40, 60 and 80GB HardDisks, DVD/CDRW! Laptop (Copy) AMD Athlon XP 1.8Ghz, 448MB RAM, 64MB Radeon Graphics, 60GB HD, DVD/CDRW!

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    Are you sure you have the right driver?

    I'm not familiar with that modem, but it looks like it's one of the winmodems supported at the Linux Winmodem website, which references the Linux drivers for Conexant chipsets website which has resources including a script to detect your chipset.

  3. #3
    Linux Newbie
    Join Date
    May 2005
    Location
    Lahore, Pakistan
    Posts
    163
    I did get my driver from linuxant. it was the suse 2.6.13-15 default driver. And only after that was I able to dial out. And when suse boots up it says starting Conexant HSF modem etc. So I think the driver is ok. I've tried two different ISPs aswell. In kppp i am able to connect but it randomly disconnects saying "pppd daemon died unexpectedly EXIT STATUS 16" which means that the modem hung up. So this the problem I'm facing.
    Registered Linux User #395492
    My blog: http://www.khooban.com/nucleus/?&blogid=2
    Desktop (Cassius) Pentium 4 1.5Ghz, 512MB SDRAM, 40, 60 and 80GB HardDisks, DVD/CDRW! Laptop (Copy) AMD Athlon XP 1.8Ghz, 448MB RAM, 64MB Radeon Graphics, 60GB HD, DVD/CDRW!

  4. #4
    Linux Newbie
    Join Date
    May 2005
    Location
    Lahore, Pakistan
    Posts
    163
    I just tried some new stuff. I connected via ethernet and download the cnxtinstall.run file from linuxant which helped me install and configure the driver. Afterwards I tried kinternet and got this "SuSE Meta pppd (smpppd-ifcfg), Version 1.59 on linux.
    Status is: disconnected
    trying to connect to smpppd
    connect to smpppd
    Status is: disconnected
    Status is: connecting
    pppd[0]: Plugin passwordfd.so loaded.
    pppd[0]: --> WvDial: Internet dialer version 1.54.0
    pppd[0]: --> Initializing modem.
    pppd[0]: --> Sending: ATZX3
    pppd[0]: ATZX3
    pppd[0]: OK
    pppd[0]: --> Sending: ATM1
    pppd[0]: ATM1
    pppd[0]: OK
    pppd[0]: --> Modem initialized.
    pppd[0]: --> Sending: ATDT0,13145678
    pppd[0]: --> Waiting for carrier.
    pppd[0]: ATDT0,13145678
    pppd[0]: CONNECT 9600
    pppd[0]: --> Carrier detected. Waiting for prompt.
    pppd[0]: ** Brain-MaxPRO Terminal Server **
    pppd[0]: Username:
    pppd[0]: --> Looks like a login prompt.
    pppd[0]: --> Sending: 95986437
    pppd[0]: 95986437
    pppd[0]: Password:
    pppd[0]: --> Looks like a password prompt.
    pppd[0]: --> Sending: (password)
    pppd[0]: Entering PPP Session.
    pppd[0]: IP address is 203.128.11.36
    pppd[0]: MTU is 1524.
    pppd[0]: --> Looks like a welcome message.
    pppd[0]: Serial connection established.
    pppd[0]: Renamed interface ppp0 to modem0
    pppd[0]: Using interface modem0
    Status is: connecting
    pppd[0]: Connect: modem0 <--> /dev/modem
    pppd[0]: replacing old default route to eth0 [192.168.2.1]
    pppd[0]: local IP address 203.128.11.36
    pppd[0]: remote IP address 203.128.11.1
    pppd[0]: primary DNS address 203.128.3.18
    pppd[0]: secondary DNS address 203.128.7.10
    pppd[0]: Script /etc/ppp/ip-up finished (pid 20177), status = 0x0
    Status is: connected
    pppd[0]: Hangup (SIGHUP)
    pppd[0]: Modem hangup
    pppd[0]: Connect time 1.9 minutes.
    pppd[0]: Sent 961 bytes, received 2573 bytes.
    pppd[0]: restoring old default route to eth0 [192.168.2.1]
    pppd[0]: Connection terminated.
    pppd[0]: Script /etc/ppp/ip-down finished (pid 20259), status = 0x0
    Status is: disconnected
    pppd[0] died: A modem hung up the phone (exit code 16)
    "

    Any ideas this is also the same problem I have in kppp.

    Thanks
    Registered Linux User #395492
    My blog: http://www.khooban.com/nucleus/?&blogid=2
    Desktop (Cassius) Pentium 4 1.5Ghz, 512MB SDRAM, 40, 60 and 80GB HardDisks, DVD/CDRW! Laptop (Copy) AMD Athlon XP 1.8Ghz, 448MB RAM, 64MB Radeon Graphics, 60GB HD, DVD/CDRW!

  5. #5
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    It looks like the software is working and the modem is hanging up. You might try adding some things to the AT command.

    Your phone company may have a code that disables phone features, maybe *70. You can add this to the phone number: ATDT*70,0,13145678

    If the modem was not manufactured for your country, it may have the wrong default encoding. In the US, all phone lines use mu-law, but much of the rest of the world uses A-law. On a modem that supports the Hayes command set, you can send "%U0" (as part of the modem setup, ATZX3%U0) to select mu-law or "%U1" to select A-law. I don't know about these Conexant modems though. But wait--you actually received DHCP information, so this seems unlikely.

    Other Hayes commands allow you to disable/enable line quality monitoring, and do lots of esoteric operations that probably won't help, but have some possibility. But again, the Winmodems may not support them.

    You might also try M2 (setup ATZX3M2) to leave the speaker turned throughout the entire connection to see if you can hear anything odd that would cause the hangup.

    Other things to try would be "&Q0" to turn off V.42 (just to see if it works), "\N0" to disable MNP error control (just to see if it works).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •