Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all. I just set up ukonline opensurf unmeterd internet acess thing but wvdial bums out with exit code #16 "a modem hung up the phone" I can connect to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296

    ukonline opensurf - wvdial wont connect


    Hi all.

    I just set up ukonline opensurf unmeterd internet acess thing but wvdial bums out with exit code #16 "a modem hung up the phone" I can connect to totalise isp no problem.. any ideas? he is wvdial settings:


    [Dialer Defaults]
    Modem = /dev/ttyS2
    Baud = 115200
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ISDN = 0
    Modem Type = Analog Modem
    Phone = <08089933259>
    Username = mr*******
    Password = *********


    is this all normal? should i include the DNS adresses - it says its server assigned ont he website. i phoned the support helpline they are nothing but friendly muppets.

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    Variant,
    what does a
    Code:
    tail --lines 60 /var/log/messages
    show?

    I'm guessing that it's failing on the CHAP/PAP bit. Have you setup your userid and password in the PAP and CHAP secret files (somewhere in /etc/)?

    have fun

    Nerderello
    ps. what part of the Shetlands are you on? I, many years ago, lived on Unst.

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    bash-2.05b# tail --lines 60 /var/log/messages
    tail: /var/log/messages: No such file or directory

    im useing gentoo - i have no idea where such log is stored. heer is the output from wvdial:

    bash-2.05b# wvdial
    --> WvDial: Internet dialer version 1.53
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT08089933259
    --> Waiting for carrier.
    ATDT08089933259
    CONNECT 115200
    --> Carrier detected. Waiting for prompt.
    ~[7f]}#@!}![1d]} }9}"}&} }*} } }#}%B#}%}%}&]yqm}'}"}(}"`d~
    --> PPP negotiation detected.
    --> Starting pppd at Sat Feb 21 08:53:47 2004
    --> pid of pppd: 1091
    --> Disconnecting at Sat Feb 21 08:53:51 2004
    --> The PPP daemon has died: A modem hung up the phone (exit code = 16)
    --> man pppd explains pppd error codes in more detail.
    --> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
    --> Auto Reconnect will be attempted in 5 seconds


    /etc/ppp/pap-secrets and /etc/ppp/chap-secrets are both empty files. also normal users cant run wvdial - it says device busy so at the momment i can only run it as root :o. I really have no idea when it comes to setting up ppp in linux as this is the first time i have had to use it. (i lived with my brother for a few years up untill now and used his connection over the network)

    I live in Quarff a few miles south of lerwick.. how long ago were you in unst? are you a shetlander by birth? Norik beach owns! ( i allwase holiday in unst)

  4. #4
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    I got the same error. The first time I had suse installed it worked fine then i borked it and i got the error....i havent been able to fix it so eventualy i set my xp (gag) puter up as a router/ICS. I dont know how to fix it but your not alone and im gonna watch this thread.

    <edit>I forgot...I had to use setserial to get the modem to work and if you specify 'no-hup' or something like that (its in the man pages) it doesnt work either.</edit>
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  5. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    i rebooted and checked out the isp [ukonline] in suse 8.0 using kinternet - it works fine. but creates what seems to be strange output, heer it is:


    Starting connection. (2004-02-21 09:40:59 GMT)
    pppd: Plugin passwordfd.so loaded.
    pppd: Perms of /dev/ttyS2 are ok, no 'mesg n' neccesary.
    pppd: --> WvDial: Internet dialer version 1.42
    pppd: --> Initializing modem.
    pppd: --> Sending: ATZ
    pppd: ATZ
    pppd: OK
    pppd: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    pppd: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    pppd: OK
    pppd: --> Sending: ATM1
    pppd: ATM1
    pppd: OK
    pppd: --> Modem initialized.
    pppd: --> Sending: ATDT08089933259
    pppd: --> Waiting for carrier.
    pppd: ATDT08089933259
    pppd: CONNECT 57600
    pppd: --> Carrier detected. Waiting for prompt.
    pppd: ~[7f]}#@!}!u} }9}"}&} }*} } }#}%B#}%}%}&^%}/+}'}"}(}"{=~
    pppd: --> PPP negotiation detected.
    pppd: Serial connection established.
    pppd: using channel 1
    pppd: Using interface ppp0
    pppd: Connect: ppp0 <--> /dev/ttyS2
    pppd: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xab0c0cd6> <pcomp> <ac$
    pppd: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xab0c0cd6> <pcomp> <ac$
    pppd: rcvd [LCP ConfReq id=0xf6 <asyncmap 0xa0000> <auth chap MD5> <magic 0x$
    pppd: sent [LCP ConfAck id=0xf6 <asyncmap 0xa0000> <auth chap MD5> <magic 0x$
    pppd: sent [LCP EchoReq id=0x0 magic=0xab0c0cd6]
    pppd: cbcp_lowerup
    pppd: want: 2
    pppd: rcvd [CHAP Challenge id=0xcb <26784f191ea37575e679f98091cdb39f>, name $
    pppd: sent [CHAP Response id=0xcb <bf3d77b8cd0c6be543eb31f36a543b3f>, name =$
    pppd: rcvd [LCP EchoRep id=0x0 magic=0x5e250f2b]
    pppd: rcvd [CHAP Success id=0xcb ""]
    pppd: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01> <ms-dns1 $
    pppd: sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
    pppd: rcvd [IPCP ConfReq id=0x1 <addr 212.135.11.11>]
    pppd: sent [IPCP ConfAck id=0x1 <addr 212.135.11.11>]
    pppd: rcvd [LCP EchoReq id=0x1 magic=0x5e250f2b 75 e6 79 f9]
    pppd: sent [LCP EchoRep id=0x1 magic=0xab0c0cd6 15 03 2f 01]
    pppd: rcvd [IPCP ConfRej id=0x1 <compress VJ 0f 01>]
    pppd: sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.$
    pppd: rcvd [LCP ProtRej id=0x1 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 $
    pppd: rcvd [IPCP ConfNak id=0x2 <addr 217.205.241.237> <ms-dns1 212.135.1.36$
    pppd: sent [IPCP ConfReq id=0x3 <addr 217.205.241.237> <ms-dns1 212.135.1.36$
    pppd: rcvd [IPCP ConfAck id=0x3 <addr 217.205.241.237> <ms-dns1 212.135.1.36$
    pppd: local IP address 217.205.241.237
    pppd: remote IP address 212.135.11.11
    pppd: primary DNS address 212.135.1.36
    pppd: secondary DNS address 212.135.1.38
    pppd: Script /etc/ppp/ip-up started (pid 2999)
    pppd: Script /etc/ppp/ip-up finished (pid 2999), status = 0x0
    We are connected. (2004-02-21 09:41:30 GMT)
    pppd: rcvd [LCP EchoReq id=0x2 magic=0x5e250f2b d4 87 01 24]
    pppd: sent [LCP EchoRep id=0x2 magic=0xab0c0cd6 d4 87 01 24]
    pppd: sent [LCP EchoReq id=0x1 magic=0xab0c0cd6]
    pppd: rcvd [LCP EchoRep id=0x1 magic=0x5e250f2b]
    pppd: rcvd [LCP EchoReq id=0x3 magic=0x5e250f2b d4 87 01 24]
    pppd: sent [LCP EchoRep id=0x3 magic=0xab0c0cd6 d4 87 01 24]
    pppd: rcvd [LCP EchoReq id=0x4 magic=0x5e250f2b d4 87 01 24]
    pppd: sent [LCP EchoRep id=0x4 magic=0xab0c0cd6 d4 87 01 24]
    pppd: rcvd [LCP EchoReq id=0x5 magic=0x5e250f2b d4 87 01 24]
    pppd: sent [LCP EchoRep id=0x5 magic=0xab0c0cd6 d4 87 01 24]
    pppd: sent [LCP EchoReq id=0x2 magic=0xab0c0cd6]
    pppd: rcvd [LCP EchoRep id=0x2 magic=0x5e250f2b]
    pppd: rcvd [LCP EchoReq id=0x6 magic=0x5e250f2b d4 87 01 24]
    pppd: sent [LCP EchoRep id=0x6 magic=0xab0c0cd6 d4 87 01 24]
    pppd: rcvd [LCP EchoReq id=0x7 magic=0x5e250f2b d4 87 01 24]

    how can i configure this connection to work with wvdial in gentoo?

  6. #6
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    taht last output tells me its using chap authentiaction. u need to add to /etc/ppp/chap-secrets
    "username" * "password"

    and then it shoudl go. if it doesnt try readign thru my similar problem here

    http://www.linuxforums.org/forum/vie...507&highlight=

    there is a link to a tutorial at the end which is real useful

    hope this helps at least 1 of u

  7. #7
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    exeptional. thanks bud that fixed me up totaly! I was the chap-secrets thing after all.

  8. #8
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    Variant,
    no, I'm not an islander. I was up in Saxa Vord (nr Haroldswick) many years ago with the forces.

    Glad you got the internet working.

    PS. the "tail" command is just like "cat" and "head" and I thought were part of all Linuxs. As you know "cat" shows all of the files contents, "Head" does the first 30 lines and tail does the last 30 (unless you tell it otherwise).

    And as for the message logs, I though that they too were in the same place (/var/log/) in all Linuxs.

    have fun

    Nerderllo

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •