Find the answer to your Linux question:
Results 1 to 3 of 3
Not sure if Ive done this right as I still cant get internet access. This is how i have the settings at the moment: Ip address: 192.168.1.225 Subnet mask: 255.255.255.0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2

    Help with Static IP settings on Suse 10.1


    Not sure if Ive done this right as I still cant get internet access. This is how i have the settings at the moment:

    Ip address: 192.168.1.225
    Subnet mask: 255.255.255.0

    Under the hostname & Name server ooptions:

    Hostname: linux-8fq1
    Domain Name: site
    (The box next to Change hostname via DHCP is checked, is this correct? I am not assigning the ip's via DHCP)

    Under Name Servers & Domain Search List:

    Name Server 1: 192.168.0.254
    In the box under Domain Search it has site entered.

    I have the default gateway set to 192.168.0.254.

    Is there something I have done wrong here or missed a setting.

    Cheers

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Is 192.168.0.254 the address of your router? Using your router's address as the gateway is right, but the Name Server(s) should be the address(es) provided by your ISP for DNS resolution, not your router's address. This is especially important when using a static address, because then you don't have a DHCP server setting DNS addresses for you.

    Also, if the above is your router's address, you'll have an easier time if the first three octets in your machine's IP address are the same as the router, e.g., 192.168.0.225 instead of 192.168.1.225.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2
    Quote Originally Posted by Zelmo
    Is 192.168.0.254 the address of your router? Using your router's address as the gateway is right, but the Name Server(s) should be the address(es) provided by your ISP for DNS resolution, not your router's address. This is especially important when using a static address, because then you don't have a DHCP server setting DNS addresses for you.

    Also, if the above is your router's address, you'll have an easier time if the first three octets in your machine's IP address are the same as the router, e.g., 192.168.0.225 instead of 192.168.1.225.
    Thanks, that has fixed it. The strange thing is that in Windows it works OK. Oh, well i guess thats life for you!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •