Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Unhappy ping: unknown host

    Hey all - I've run into a problem that I'm unable to diagnose.

    I orginially noticed because clamav was having a spastic trying to update it definations.

    Basically, I can't seem to resolve any hostnames from my linux box.

    > ping
    ping: unknown host
    Yet, my DNS seems to be working correctly.. I'm not running my own DNS server, or DHCP - merely using the server my ISP provides.

    > dig
    ; <<>> DiG 9.3.0 <<>>
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64369
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 6, ADDITIONAL: 6
    ;                        IN      A
    ;; ANSWER SECTION:         515170  IN      CNAME       73      IN      A       73      IN      A       73      IN      A
    ;; AUTHORITY SECTION:           83172   IN      NS           83172   IN      NS           83172   IN      NS           83172   IN      NS           83172   IN      NS           83172   IN      NS
    ;; ADDITIONAL SECTION:         83189   IN      A         83189   IN      A         83189   IN      A         83189   IN      A         83189   IN      A         83189   IN      A
    ;; Query time: 19 msec
    ;; SERVER:
    ;; WHEN: Mon Jul 24 11:46:06 2006
    ;; MSG SIZE  rcvd: 292
    I can reach IP addresses when pinging, but not hostnames. Weirdly enough our email is still functioning quite happily on this box too postfix/courier-imap).

    Quite frankly I'm not sure how to procede from here - so any help would be greatly appreciated!

    /etc/resolv.conf follows

  2. #2
    Try adding the following two lines to /etc/modprobe.conf

    alias net-pf-10 off
    alias ipv6 off

    If you have a firewall running, I would disable that one, too and check the connection again. And finally, if nothing helps, you might need to fine tune the MTU and MRU settings of your network. If you use a router, reset it to factory to the defaults. Maybe that helps.
    Windows free since 2002 | computing since 1984

  3. #3
    Ok - turns out I had removed the dns option from my hosts entry in nsswitch.conf

    I'm a dumbass

    At least its all working again now.

  4. $spacer_open
  5. #4

    solved the ping problem


    I too had the same problem. I could ping Ip address but not hostnames. I corrected my nsswitch.conf file and it worked properly.

    Manish Shrestha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts