Find the answer to your Linux question:
Results 1 to 3 of 3
All, I seem to be running in a bit of circle here and I'm not sure what I'm missing. My Windows XP clients cannot access my debian fileserver which is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2003
    Posts
    7

    Setting up Samba to accept any computer in the workgroup


    All,

    I seem to be running in a bit of circle here and I'm not sure what I'm missing. My Windows XP clients cannot access my debian fileserver which is hostname "debianserver". Here is what I'm trying to do:

    I have a protected LAN where I trust all the computers that are able to gain an IP from my router and that are in the same workgroup. I've taken many steps to prevent unwanted access to the LAN. Let's call this workgroup "GAMMA" from here on out.

    I want any computer associated to this workgroup to have read/write access to a shared folder called "shared files" That sounds simple enough but I can't seem to get it to work correctly. All the other computers do not have logins...that is to say you start Windows by clicking on a user but you don't have to enter a username and password or authenticate with any other server. I'm a little fuzzy here on if these users have associated passwords I need to programmatically account for.

    Initially when I configured smb.conf I was able to see and browse the share in Network Neighborhood but could not write to it. After some changes to smb.conf and a few permission changes to the "shared files" folder using chmod I can still see the folder "shared files" but I cannot access it any further than the top folder. I recieve "\\debianserver\shared files is not accessible. You might not have permissions...". The permissions are set as follows:

    drwxrw-rw- 7 root staff 4096 2006-07-29 17:01 shared files

    Here are the uncommented lines of my smb.conf file:

    [global]
    workgroup = GAMMA
    server string = %h server (Samba %v)
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    security = share
    encrypt passwords = true
    passdb backend = tdbsam guest
    obey pam restrictions = yes
    invalid users = root
    passwrd program = usr/bin/passwd %u
    socket options = TCP_NODELAY

    [shared files]
    comment = Shared Files
    path = /home/shared files
    writable = yes
    guest ok = yes

    [homes]
    comment = Home Directory
    browseable = no
    writable = no
    create mask = 0775
    directory mask = 0775

    I appreciate any help on this one...thanks in advance!

  2. #2
    Just Joined! .:neogeo:.'s Avatar
    Join Date
    May 2006
    Posts
    15
    Hi Star,

    In your shared files area try adding browseable = yes.

  3. #3
    Just Joined!
    Join Date
    Aug 2003
    Posts
    7
    That did the trick! Thank you...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •