I don't know anything about the settings people are talking about in previous replies.
But, I was unable to use samba shares after I installed a firewall on my linux (ubuntu) machine.

Pretty obvious, but,.. have you got a firewall running on your linux machine ?, see if disabling it fixes your problem, and if it does, adjust the settings to allow local network traffic pertinent to file shares before re-starting.