Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hello! I'm trying to conecto my Windows XP to my Madriva 2006 Linux with samba. I have 2 main problems that most likely are related: 1) Unable to conect from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3

    SAMBA Win XP Conection Problem


    Hello!
    I'm trying to conecto my Windows XP to my Madriva 2006 Linux with samba.

    I have 2 main problems that most likely are related:
    1) Unable to conect from Windows to Linux
    2) Unable to mount windows shares in Linux

    When I browse My Network Places, I can't get the Linux machine.
    When I use ms-dos "net view" I don't see the Linux Samba server.
    I turned off my Sygate firewall already in XP and I haven't configure any in Linux, as far as I know.

    I can ping both machines even with the host name intead of the IP address.
    I have assigned to the WINS address, the IP of the Linux samba server, in the TCP/IP Advanced Properties in Win XP.

    I have followed each and every step of the Howto that I found in this forum:
    http://www.linuxforums.org/forum/lin...ups-howto.html

    I have gone through a lot of reading trying to solve this issue, but so far, nothing. I can't conect Windows to Linux.
    Please help me a little here, because I don't think this will be a big issue. I have the feeling that something is missing.

    Follow are my config:
    Linux gbox 2.6.12-12mdk #1 Fri Sep 9 18:15:22 CEST 2005 i686 Intel(R) Pentium(R) 4 Mobile CPU 1.60GHz unknown GNU/Linux

    I have already installed and configured samba.
    My smb.conf is like this:
    #====== Global Settings ===
    [global]

    workgroup = casa
    netbios name = gbox
    server string = Samba Server %v
    security = user
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    username map = /etc/samba/smbusers

    log file = /var/log/samba/%m.log
    socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192

    wins support = yes
    hostname lookups = yes
    hosts equiv = /etc/hosts
    hosts allow = 192.168.0.1 127.0.0.1 localhost
    hosts deny = All
    interfaces = lo eth0
    bind interfaces only = yes
    guest ok = no
    browse list = yes
    printcap name = cups
    printing = cups
    load printers = yes

    domain master = no
    local master = no
    preferred master = no
    os level = 0

    #==== Share Definitions ====
    [public]
    path = /home/samba/public
    comment = Shared folders
    guest ok = no
    create mode = 0766
    browseable = yes
    public = yes
    read only = no

    [homes]
    path = /home/%U
    comment = Home Directories
    browseable = no
    read only = no
    valid users = %U root

    -------------------------

    When I do a testperm, I get this:
    Load smb config files from /etc/samba/smb.conf
    Processing section "[public]"
    Processing section "[homes]"
    Loaded services file OK.
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions


    In Linux I can conect to the local samba server with smbclient and see all the shares:
    smbclient -L //localhost/public
    Domain=[GBOX] OS=[Unix] Server=[Samba 3.0.20]

    Sharename Type Comment
    --------- ---- -------
    public Disk Shared folders
    IPC$ IPC IPC Service (Samba Server 3.0.20)
    ADMIN$ IPC IPC Service (Samba Server 3.0.20)
    root Disk Home Directories

    Domain=[GBOX] OS=[Unix] Server=[Samba 3.0.20]

    Server Comment
    --------- -------

    Workgroup Master
    --------- -------
    CASA

    It seems the server is running well and the smbd and nmbd deamons are ok.

    Please, any help would be apreciated.
    Thanks

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    8
    Did you try to find linux machine by Find Computer or typing name ins explorer address window like \\winhostname ??

    And can you post output for ifconfig(linux) and ipconfig(win)??

  3. #3
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    I see "Server role: ROLE_STANDALONE" in the testparm output, and "domain master = no" in smb.conf.
    Mine says "Server role: ROLE_DOMAIN_MEMBER", and also "domain master = no".

    What domain is the Windows PC in and is it the domain master? If it's in GBOX and there is a domain master, then you need to join the domain (and probably set "security = ADS"). If it's something else, I think you need to either switch to it and join it, or be the domain master of GBOX.

    If you have just these two PCs, and you are not trying to join any larger Windows network, it would probably be simplest to allow the Linux PC to be the domain master and make the Windows PC join the GBOX domain.

  4. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    I agree with Ken Jackson, what is your network setup? It's hard to troubleshoot the smb.conf when we don't know what your Global Settings should be. In addition, have you disabled or at least allowed SMB services via your firewall? Have you restarted smb after changing the smb.conf?

    As for simple SMB/CIFS firesharing, you don't need to be a domain member (if you are using one) for authentication/Samba access unless you are using ADS authentication. In reviewing your smb.conf you are using User authentication which is fine so long as the appropriate smb users are added to the machine.

    Have you double and triple checked your TCP/IP settings - ensuring that you machines are on the same IP subnet? I would focus my hunt for this problem with your network and firewall settings. Then once you confirm this, make sure to restart the Samba daemon.

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3

    Smile Replying your posts

    First of all, thanks for providing this help.

    Here we go now...

    kmokrzycki:
    I've tryed typing name ins explorer address window as you said, but nothing. Even "net view" only show me the Windows machine:
    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    ipconfig output
    ---------------
    Windows IP Configuration

    Ethernet adapter Home:
    Connection-specific DNS Suffix . :
    IP Address. . . . . . . . . . . . : 192.168.0.1
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :

    Ethernet adapter TV Cabo:
    Connection-specific DNS Suffix . : ######## (Internet provider)
    IP Address. . . . . . . . . . . . : 85.139.235.42
    Subnet Mask . . . . . . . . . . . : 255.255.254.0
    Default Gateway . . . . . . . . . : 85.139.235.254

    ifconfig output
    ----------------
    eth0 Link encap:Ethernet HWaddr 00:08:02:6B:C2:E7
    inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::208:2ff:fe6b:c2e7/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:46 errors:0 dropped:0 overruns:0 frame:0
    TX packets:855 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:5588 (5.4 KiB) TX bytes:42082 (41.0 KiB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:338 errors:0 dropped:0 overruns:0 frame:0
    TX packets:338 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:20348 (19.8 KiB) TX bytes:20348 (19.8 KiB)


    Just to ble clear, the network is working fine, I can ping both computers and I can share the Internet conection from Windows to Linux (ie. My Internet conection is on the Windows machine).
    I don't use any domain. I just use a workgroup which works well if I conect both the laptop and the desktop in Windows XP.
    Now I just want to share some folderes in the Linux laptop to the Windows desktop. I did this once and it worked well, asking the samba passwords and all of that.

    KenJackson:
    "Server role: ROLE_STANDALONE" in the testparm output -> I also find this strange, because. But how can I change this?

    "domain master = no" in smb.conf -> I'v tried already without this line and nothing.

    "it would probably be simplest to allow the Linux PC to be the domain master and make the Windows PC join the GBOX domain"
    It's not possible just to join a windows Worgroup with Samba without using domains?

    gtmtnbiker98
    In addition, have you disabled or at least allowed SMB services via your firewall?
    I'm not using any firewall at all. I turned off my Windows Sygate FW.

    Have you restarted smb after changing the smb.conf?
    You don't want to know ho many times I did that already

    In reviewing your smb.conf you are using User authentication which is fine so long as the appropriate smb users are added to the machine.
    Everything is fine with the SMB users and all the passwords are sett. I can conect localy to the samba shares (ie. from linux) withou any problems.

    Have you double and triple checked your TCP/IP settings - ensuring that you machines are on the same IP subnet?
    As you can see by the ipconfig and ifconfig, it seems everything is on the right place.

    Then once you confirm this, make sure to restart the Samba daemon.
    You mean this commands?
    /etc/init.d/smb stop
    /etc/init.d/smb start
    This is what I have been doing.

    Once again thanks for your support.
    I'm getting crazy with this situation and I really need to put this machines running together.

  6. #6
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    I agree, nothing obvious on the TCP/IP settings, and you've disabled any firewalls on the Linux box, correct? Try editing the following:

    #==== Share Definitions ====
    [public]
    path = /home/samba/public
    comment = Shared folders
    force user = owner of /home/samba/public
    valid users = yoursmbusers
    user = yoursmbusers
    write list = yoursmbusers

    Then type /etc/init.d/smb restart

    Also, your workgroup is Casa and the machine name is Gbox, right? You have for sure set the smb passwords and added the users using the smbpasswd -a username, correct?

  7. #7
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    It's not possible just to join a windows Worgroup with Samba without using domains?
    Maybe you can, since you are using "security = user". I've only used it in an office that had a domain controller.

    Try these on the Windows machine:
    > net view /DOMAIN:CASA
    > net view /WORKGROUP:CASA
    > net view \\gbox /DOMAIN:CASA
    > net config workstation

    And on the Linux machine (respond to prompt with Windows password):
    $ smbclient -U windowsusername -L gbox
    or
    $ smbclient -N -L gbox

  8. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3

    Some more tests

    Take a look at the outputs of the Windows "net view":

    net view /DOMAIN:CASA
    Server Name Remark
    -----------------------------------
    \\BIGBOX Desktop
    The command completed successfully.


    net view /WORKGROUP:CASA -> doesn't seem a valid sintaxe

    net view \\gbox /DOMAIN:CASA
    System error 53 has occurred.
    The network path was not found.

    net config workstation
    Computer name \\BIGBOX
    Full Computer name BigBox
    User name ....

    Workstation active on
    ........................
    Software version Windows 2002

    Workstation domain CASA
    Workstation Domain DNS Name (null)
    Logon domain BIGBOX

    COM Open Timeout (sec) 0
    COM Send Count (byte) 16
    COM Send Timeout (msec) 250
    The command completed successfully.

    As you can see, althoug I havn't defined any Domain, it says "Workstation domain".
    I have defined only a Workgroup in Win XP. I have used already the wizard a couple of times in order to set the Netowk Identification properly.
    I also have Net Bios, Net Beui and TCP/IP protocols in my network, but I have disabled all but TCP/IP in order to test.
    On the Windows machine, I have 2 network cards. One for the local network and other for the Internet. I don't know if that has anything to do?
    I can access the Internet from Linux throuh the Windows gateway.

    When trying to connect from Linux to Windows with all of this commands,
    smbclient -L \\bigbox
    smbclient -U "windowsusername" -L gbox
    smbclient -N -L gbox

    I always get the same error,
    Error connecting to 127.0.0.1 (Connection refused)
    Connection to gbox failed



    I have also tryed the [publi] config of gtmtnbiker98 but the problem still happen. I think the problem is on the [global].

    Also, your workgroup is Casa and the machine name is Gbox, right?
    Yes, I have checked that a lot already.

    You have for sure set the smb passwords and added the users using the smbpasswd -a username, correct?
    Yes, everything is ok. I can also conect localy to the samba server that it works fine with all the useres.

  9. #9
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    Error connecting to 127.0.0.1 (Connection refused)
    If you have that address anywhere in your smb.conf, try commenting it out and reloading. Or add it to a "hosts allow" line.

    net view \\gbox /DOMAIN:CASA
    System error 53 has occurred.
    The network path was not found.
    Are you doing this in a Cygwin bash shell? If so you need use either \\\\gbox or '\\gobx'. (Not sure otherwise.)

    Having two network cards under Windows should be no problem as long as the routing table is correct. If you can ping gbox from bigbox and bigbox from gbox, that suggests it's correct. The command 'netstat -nr' works on both Windows and Linux to display the routing table.

  10. #10
    Just Joined!
    Join Date
    Aug 2006
    Location
    Boise, ID
    Posts
    1

    IP addresses

    So, You are using your Windoze box to do NAT?? Do you have two NICs or a PCI DSL card or are you using something external?

    At any rate, I don't believe you are getting DNS resolution. Try using IPs, the you can add your ips to the hosts files on both M$ and Linux. /etc/hosts on linux and C$/windows on M$.

    Give that a whirl.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •