Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
hey all, here's my situation. I'm using sympatico as my ISP/e-mail provider. I have a linux box using Kontact via Rogers account. I have configured Kontact to work properly while ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6

    SMTP error with mail client


    hey all,

    here's my situation. I'm using sympatico as my ISP/e-mail provider.
    I have a linux box using Kontact via Rogers account.

    I have configured Kontact to work properly while connected directly to the Symaptico DSL modem.
    Now that I have this linux box working off a Rogers modem, I can no longer send any emails.

    I get the following error:

    Sending failed:
    Could not connect to host smtp1.sympatico.ca.
    The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
    The following transport protocol was used:
    Proietto

    Some quick facts:
    No ports are blocked
    No firewall being used -- other than router, but nothing restricted
    No proxy server being used
    Usernames and passwords are verified and working

    Any suggestions ?

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    16
    Quote Originally Posted by glinux
    hey all,

    here's my situation. I'm using sympatico as my ISP/e-mail provider.
    I have a linux box using Kontact via Rogers account.

    I have configured Kontact to work properly while connected directly to the Symaptico DSL modem.
    Now that I have this linux box working off a Rogers modem, I can no longer send any emails.

    I get the following error:

    Sending failed:
    Could not connect to host smtp1.sympatico.ca.
    The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
    The following transport protocol was used:
    Proietto

    Some quick facts:
    No ports are blocked
    No firewall being used -- other than router, but nothing restricted
    No proxy server being used
    Usernames and passwords are verified and working

    Any suggestions ?
    I never used Kontact and dont know what it is but all email systems are working in the same way so I give it a try. Your problem seems to be something to do with dns name resolution
    ------------
    Are you using standard port 110 to d/l mail and port 25 to send mail?
    firstly try >nslookup smtp1.sympatico.ca
    does it resolve this name to IP?
    you should get something like below...if not then something to do with your dns setting in the ip configuration section.
    [root@frontend ~]# nslookup smtp1.sympatico.ca
    Server: 61.9.133.193
    Address: 61.9.133.193#53

    Non-authoritative answer:
    Name: smtp1.sympatico.ca
    Address: 209.226.175.63


    Secondly try to telnet to the mail server on port 25 to test communication, you should get something like below.
    --[root@frontend ~]# telnet 209.226.175.63 25
    Trying 209.226.175.63...
    Connected to smtp1.sympatico.ca (209.226.175.63).
    Escape character is '^]'.
    220 tomts10.bellnexxia.net ESMTP server (InterMail vM.5.01.06.13 201-253-122-130-113-20050324) ready Sat, 12 Aug 2006 09:45:52 -0400

    Let us know then we can go from there...

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    Here's what I got:

    o@linux:~> nslookup smtp1.sympatico.ca
    Server: 24.153.23.66
    Address: 24.153.23.66#53

    Non-authoritative answer:
    Name: smtp1.sympatico.ca
    Address: 209.226.175.63

    gino@linux:~> telnet 209.226.175.63
    Trying 209.226.175.63...
    telnet: connect to address 209.226.175.63: Connection timed out
    gino@linux:~>

  4. #4
    Just Joined!
    Join Date
    Aug 2006
    Posts
    16
    Quote Originally Posted by glinux
    Here's what I got:

    o@linux:~> nslookup smtp1.sympatico.ca
    Server: 24.153.23.66
    Address: 24.153.23.66#53

    Non-authoritative answer:
    Name: smtp1.sympatico.ca
    Address: 209.226.175.63

    gino@linux:~> telnet 209.226.175.63
    Trying 209.226.175.63...
    telnet: connect to address 209.226.175.63: Connection timed out
    gino@linux:~>
    you forgot the port number
    >telnet 209.226.175.63 25

  5. #5
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    oops

    gino@linux:~> nslookup smtp1.sympatico.ca
    Server: 24.153.23.66
    Address: 24.153.23.66#53

    Non-authoritative answer:
    Name: smtp1.sympatico.ca
    Address: 209.226.175.63

    gino@linux:~> telnet 209.226.175.63 25
    Trying 209.226.175.63...
    telnet: connect to address 209.226.175.63: Connection timed out
    gino@linux:~>

  6. #6
    Just Joined!
    Join Date
    Aug 2006
    Posts
    16
    Quote Originally Posted by glinux
    oops

    gino@linux:~> nslookup smtp1.sympatico.ca
    Server: 24.153.23.66
    Address: 24.153.23.66#53

    Non-authoritative answer:
    Name: smtp1.sympatico.ca
    Address: 209.226.175.63

    gino@linux:~> telnet 209.226.175.63 25
    Trying 209.226.175.63...
    telnet: connect to address 209.226.175.63: Connection timed out
    gino@linux:~>
    Something to do with the connection then, you need to be able to connect to your ISP mail server on port 25/TCP inorder to send mail


    This is what I get from my end, it means connection has established.
    [root@frontend ~]# telnet 209.226.175.63 25
    Trying 209.226.175.63...
    Connected to smtp1.sympatico.ca (209.226.175.63).
    Escape character is '^]'.
    220 tomts5.bellnexxia.net ESMTP server (InterMail vM.5.01.06.13 201-253-122-130-113-20050324) ready Sat, 12 Aug 2006 20:28:42 -0400

  7. #7
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    It seems I not even able to ping the smtp server at sympatico.

    Ping just times out.
    Do you think sympatico is blocking this ?

  8. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    16
    Quote Originally Posted by glinux
    It seems I not even able to ping the smtp server at sympatico.

    Ping just times out.
    Do you think sympatico is blocking this ?
    Ping uses icmp-type 8 for ping reply, most of the time they are blocking this some where in the router firewall.

    If sending mail, the port it need is 25 TCP, I could telnet to that port from my computer so your ISP is not blocking it...except they are blocking you only.

    Do you have you TCP/IP settings right?..ie default gateway address
    What IP do you have? On your machine?
    If you are using private IP behind router, does your router support NAT?
    Double check to see if your firewall/router is blocking outgoing traffic

  9. #9
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    I have already checked my router settings.
    No ports have been blocked.

    Keep in mind that i am on a different domain.

    Whenever I connect my linux connect directly to my symatico connection.....everything works.

    When I connect my linux box to the internet via an alternate provider (Rogers) .....I unable to connect to my smtp server, nor telnet into it.

    I have been told that sympatico blocks port 25 ??????????

    I'm trying to verify this, and awaiting there response, unless someone been there or has gone through this already.

  10. #10
    Just Joined!
    Join Date
    Aug 2006
    Posts
    16
    Quote Originally Posted by glinux
    I have already checked my router settings.
    No ports have been blocked.

    Keep in mind that i am on a different domain.

    Whenever I connect my linux connect directly to my symatico connection.....everything works.

    When I connect my linux box to the internet via an alternate provider (Rogers) .....I unable to connect to my smtp server, nor telnet into it.

    I have been told that sympatico blocks port 25 ??????????

    I'm trying to verify this, and awaiting there response, unless someone been there or has gone through this already.
    It sounds more like "Rogers" is blocking port 25 rather than your mail server (or it could be your mail server is blocking incoming mail from Rogers IP range). To test it out do the following to get the whole list of yahoo smtp servers.
    >nslookup <enter>
    >set type=mx <enter>
    >yahoo.com<enter>
    that should give you the whole list of yahoo mail servers.

    Then telnet to a few of them on to see if you can establish connection though port 25. You should get something like below if everything goes right

    [root@frontend ~]# nslookup
    > set type=mx
    > yahoo.com
    Server: 61.9.133.193
    Address: 61.9.133.193#53

    Non-authoritative answer:
    yahoo.com mail exchanger = 1 mx3.mail.yahoo.com.
    yahoo.com mail exchanger = 5 mx4.mail.yahoo.com.
    yahoo.com mail exchanger = 1 mx1.mail.yahoo.com.
    yahoo.com mail exchanger = 1 mx2.mail.yahoo.com.

    Authoritative answers can be found from:
    mx4.mail.yahoo.com internet address = 67.28.113.74
    mx4.mail.yahoo.com internet address = 66.218.86.156
    mx4.mail.yahoo.com internet address = 66.218.86.254
    mx1.mail.yahoo.com internet address = 4.79.181.15
    mx1.mail.yahoo.com internet address = 67.28.113.71
    mx1.mail.yahoo.com internet address = 67.28.113.73
    mx1.mail.yahoo.com internet address = 4.79.181.14
    mx2.mail.yahoo.com internet address = 4.79.181.136
    mx2.mail.yahoo.com internet address = 67.28.113.70
    mx2.mail.yahoo.com internet address = 67.28.113.72
    mx2.mail.yahoo.com internet address = 4.79.181.135
    mx3.mail.yahoo.com internet address = 67.28.113.10
    mx3.mail.yahoo.com internet address = 64.156.215.18
    mx3.mail.yahoo.com internet address = 4.79.181.134
    mx3.mail.yahoo.com internet address = 4.79.181.12
    mx3.mail.yahoo.com internet address = 67.28.113.19
    > exit

    [root@frontend ~]# telnet 67.28.113.74 25
    Trying 67.28.113.74...
    Connected to mta-v5.level3.mail.vip.re4.yahoo.com (67.28.113.74).
    Escape character is '^]'.
    220 mta374.mail.re4.yahoo.com ESMTP YSmtp service ready

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •