Find the answer to your Linux question:
Results 1 to 4 of 4
Hey guys, I've been sitting here playing around with SSH, since its a brand new concept to me (still kind of a Linux n00b), and im having some problems connecting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! daddymac117's Avatar
    Join Date
    Jan 2005
    Posts
    37

    SSH troubles from within network


    Hey guys,

    I've been sitting here playing around with SSH, since its a brand new concept to me (still kind of a Linux n00b), and im having some problems connecting properly.

    Im using a SuSE 10.0 desktop and a Knoppix 5.0.1 Live CD on a laptop. I can SSH from the laptop into the desktop with no problems at all, yet if I attempt to SSH from the desktop into the laptop, i recieve the port 22: Connection refused error.

    Both machines are running on the same network from behind a Linksys BEFW11S4 router, with both SuSE's firewall and Knoppix's firewall disabled. I can't figure out why i would be recieving an error like that with no firewalls enabled and both machines operating from within the same network.

    When I searched this forum for answers, all relevant threads were created by people recieving the port 22 connection error while trying to SSH in from outside of the network...I hadn't run across a single thread with someone trying to connect from within the same network and still recieving the port 22 connection error.

    Would anybody happen to have any ideas as to why im recieving these errors?

    Any help is appreciated!

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Is ssh server running on the laptop? That's the only thing I can think of that might give that error if firewalls are disabled on both machines.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined! daddymac117's Avatar
    Join Date
    Jan 2005
    Posts
    37
    That was the exact problem! I activated the SSH server in Knoppix, and it works fine now.

    Thanks alot!

    ...wow that was a really n00bish mistake. haha

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Quote Originally Posted by daddymac117
    ...wow that was a really n00bish mistake. haha
    Glad you got it sorted. Don't beat yourself up though because it's real easy to overlook the obvious sometimes. Just last week I was about to commit suicide because no matter what I did, I couldn't get my wife's laptop on the Internet with a new wireless card. Wasted hour after hour trying to figure out the problem only to discover I didn't have the right entries in /etc/resolv.conf
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •