Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 23
lol you should donate to dapper dan or bigtomrodney for all the work they do around here in general, instead of a useless linux zealot like me I really wish ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined! Sam Liu's Avatar
    Join Date
    Aug 2006
    Location
    USA baby
    Posts
    78

    lol you should donate to dapper dan or bigtomrodney for all the work they do around here in general, instead of a useless linux zealot like me

    I really wish I knew more about this but I dont see anything wrong so its befuddling me. All I can do is BUMP this thread

  2. #12
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Thanks for the help Sam!

    Can anyone else help me?

  3. #13
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by LiveFree
    Just an update on the situation:

    I ran these commands:

    Code:
    modprobe -r ndiwrapper
    modprobe -r bcm43xx
    modprobe ndiswrapper
    and VIOLA! the ndiswrapper(wlan0) reference is BACK in the Wireless devices diaglog box, but I cannot activate it.

    If it matters,
    I can see the ndiswrapper(wlan0), the Full Card name (Broadcom Corp. bcm......), and 'Other Cards' listed in the dialog box.

    So the problem here might have been caused by a kernel update from fedora...I think you have to recompile ndiswrapper it after every kernel update. I could be wrong though, anyhoo you said
    and VIOLA! the ndiswrapper(wlan0) reference is BACK in the Wireless devices diaglog box, but I cannot activate it.
    Are you getting some kind of error msg? unable to assign an IP? Can't find access point?
    Have you re-compiled ndiswrapper and made sure all the settings have not been changed?
    Have you tried depmod -a before inserting modprobe ndiswrapper?
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. #14
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Ok so I just did a:

    'make clean'
    'make'
    'make install'
    'ndiswrapper -e bcmwl5' (old driver from last attempt)
    'ndiswrapper -i ~/Desktop/80211g/bcmwl5.inf'
    'depmod -a' (No output)
    'modprobe ndiswrapper'
    And I added the alias wlan0 ndiswrapper in /etc/modprobe.conf

    And I STILL dont see the ndiswrapper(wlan0) in the Wireless Devices dialog.

  5. #15
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133

    Sorry...

    Quote Originally Posted by LiveFree
    Hey Thanks Sam Liu
    I currently have the bcmwl5 driver installed in ndiswrapper, but I had heard of FedoraForum that sometiems the bcm43xx driver can interfere with the ndiswrapper so I blacklisted it.
    I'm sorry I haven't been back to you , I'm usually only jumping in and out of the forums and I must have missed your post.
    If you are using a broadcom device, you can make the choice between ndiswrapper (which has caused you trouble) or use the bcm43xx driver - that is remove it from the blacklist.What you need to do then is follow up with getting the firmware. You see the bcm43xx driver works fine, but your card relies on some firmware to get it going which can't be freely distributed. There is a piece of software called bcm43xx-fwcutter

    here's a link - http://rpmfind.net/linux/rpm2html/se...m43xx-fwcutter

    Basically when you install this you can use it to dump the firmware you need and install it for you from the bcwl5.sys in your windows driver. The command should go something like this -
    Code:
    sudo bcm43xx-fwcutter -w /lib/firmware bcmwl5.sys
    I hope this gets it going for you, and if you have any questions just send me a private message to remind me to check back on this. Hopefully we'll get you sorted.

  6. #16
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Hey There,

    Np about the latency. Ive tried the fwcutter route and it didnt work out for me (couldnt activate the Card [although I did see the entry in Wireless Devices box])

    I would like to stick with ndiswrapper if possible.

    Like Ive said, I jsut recompiled and re-added the ndiswrapper / driver and I cant see the alias

  7. #17
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Ok well I re-did the whole bcm43xx driver stuff with fwcutter

    'modprobe -r ndiswrapper'
    Deleted everything except eth0 from Network Connections
    'bcm43xx-fwcutter -w ~/Desktop/80211g/bcmwl5.sys'
    'depmod -a' (Nothing)
    'modprobe bcm43xx'
    Added 'alias wlan0 bcm43xx' to 'etc/modprobe.conf'

    And all is well because I see bcm43xx(wlan0) in Network devices and I added it, but when I try to activate it I see that the 'bcm43xx device wlan0 does not seem to be present, delaying init.'

    Thanks!

    PS-I would LOVE not to have to do a re-install (ive done 1 twice because of this before

    EDIT: Ok I just restarted, and I dont see the bcm43xx listed in the Wireless Devices box.

    'iwconfig' shows a eth1 (no wlan0 mentioned).

    I did the modprobe bcm43xx, dhclient eth1 / wlan0 after restart, but I still cant activate anything.

  8. #18
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I have found that the bcm driver names the card eth1. It'd be nice if they'd standardise - right now I'm working with a realtek which is called ra0.

    The wlan0 device looks like the ndiswrapper device, maybe it was a hangover before rebooting. Do you have Network Manager or similar installed? I'm off to bed now, I'll pick this up in the morning.

  9. #19
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    EDIT:

    I have this feeling that we are getting SOO close. The card light is on as soon as I start the computer.

    I de-modeprobe ndiswrapper and modprobe bcm43xx and go into Networks. I see bcm43xx(wlan0) and I add it, BUT I cant activate it.

    I have the alias in modprobe.conf as wlan0, and its shown as wlan0 in Networks BUT 'iwconfig' shows eth1. If I change the alias to eth1, then the bcm43xx(eth1) doesnt show up in Networks.

    And when I activate it (when it fails, says bcm43xx device wlan0 does not seem to be present, delaying init.), the card light stays on though.

    I do have NetworkManager installed and when I first boot, where it says 'Starting clock:' instead of giving the time (since Ive ndiswrapper -e'ed all the drivers out) it shows a message about no drivers from ndiswrapper.

  10. #20
    Just Joined! Sam Liu's Avatar
    Join Date
    Aug 2006
    Location
    USA baby
    Posts
    78
    I think you might need to blacklist yet another driver. for my card, I had to blacklist 3 drivers (islsm, islsmusb, islsm-usb)

    when I only did one, I got something similar.

    to find what that driver is, maybe you can look at the device manager and everything under your card's title? find what driver(s) it actually is using and type them here?

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •