Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
Ok, Well a week ago after restarting, I found that my ndiswrapper(wlan0) listing in my 'Create New Connection = > Wireless' wizard was gone and therefore the WiFi card would ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57

    ndiswrapper not working after reboot?


    Ok,

    Well a week ago after restarting, I found that my ndiswrapper(wlan0) listing in my 'Create New Connection = > Wireless' wizard was gone and therefore the WiFi card would not work. (Broadcom bcm431.

    Now after posting here and not recieving a response for 2 weeks, I re-installed.

    This time I went through all the instructions to install ndiswrapper (I had to add a symlink so it would find the devel) and I installed the 'patch' to upgrade the 4k cache.

    ndiswrapper -l shows that the driver is installed and hardware present.

    Before I try to activate the card in the Network settings wizard, I run:

    depmod -a (nothing)
    modprobe ndiswrapper (ok)
    dhclient wlan0

    I added an alias in modprobe.conf and blacklisted bcm43xx

    And I create the connection,but when I try to activate it, it says that it cannot.

    Running iwconfig shows that there is no wlan0.

    And now, after restarting, I find that ONCE AGAIN, the reference to ndiswrapper(wlan0) is gone AGAIN in the Network box so the WiFi wont work. (Not like it did in the first place).

    Im getting desperate on this, I am willing to make a donation in a very-helpful person's name to the Fedora group.

    Thank You,
    Rick

    EDIT: And I did update the kernal before installing ndiswrapper

    EDIT *2: I just restarted and I see that ndiswrapper command isnt even found in the system, so I guess it is that ndiswrapper is disappearing after a restart.

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    What distro are you using?Generally you need to run
    Code:
    sudo ndiswrapper -m
    to run the modprobe configuration on boot. This works for most distros with the exception of SUSE, which works a little differently.

    For SUSE to get the module to permanently load on boot go into YaST > /etc/sysconfig editor. Go into the tree of settings and browse to System > Kernel > MODULES_LOADED_ON_BOOT and add 'ndiswrapper'.

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Sorry, Fedora Core 5.

    Sorry I hadnt mentioned it...
    Isnt that the same as modprobe ndiswrapper? And does that have anything to do with the fact that ndiswrapper seems to disappear?

    And I did run that command with no affect, said modprobe config files already had that alias.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Can you run these commands and post back the results please-
    Code:
    which ndiswrapper
    less /etc/modprobe.conf
    ifconfig
    iwconfig
    dmesg |grep -i ndiswrapper
    dmesg |grep -i wlan
    dmesg |grep -i bcm
    dmesg |grep -i broadcom
    I know you mention you have already modified some of these files/commands but I'd like to get everything in context.
    Last edited by bigtomrodney; 08-19-2006 at 08:39 PM.

  6. #5
    Linux Newbie
    Join Date
    Sep 2004
    Location
    Aberdeen, Scotland
    Posts
    204
    Have a look here if you haven't already - http://ndiswrapper.sourceforge.net/m..._configuration . Some success there by adding "/sbin/modprobe ndiswrapper" to /etc/rc.d/rc.local and blacklisting bcm43xx as you have already done.
    Elive,kanotix-mini,pclinuxos super gamer,xp, sidux

  7. #6
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Ok, well I had to re-install ndiswraper since when I did /sbin/ndiswrapper I couldnt run any of the ndiswrappr commands...

    Ok I just re-installed ndiswrapper, and looking at the Wireless device list, I dont see ndiswrapper(wlan0)

    Terminal Results (listed in order of the commands given above)

    /usr/sbin/ndiswrapper

    alias eth0 8139too
    alias snd-card-0 snd-atiixp
    options snd-card-0 index=0
    options snd-atiixp index=0
    remove snd-atiixp { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-atiixp
    alias wlan0 ndiswrapper

    eth0 Link encap:Ethernet HWaddr 00:C0:9F:E9:EF:6A
    inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::2c0:9fff:fee9:ef6a/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:5470 errors:0 dropped:0 overruns:0 frame:0
    TX packets:5653 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:6046061 (5.7 MiB) TX bytes:851310 (831.3 KiB)
    Interrupt:193

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2346 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2346 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2771925 (2.6 MiB) TX bytes:2771925 (2.6 MiB)

    lo no wireless extensions.

    eth0 no wireless extensions.

    sit0 no wireless extensions.

    Warning: Driver for device wlan0 has been compiled with version 20
    of Wireless Extension, while this program supports up to version 19.
    Some things may be broken...

    wlan0 IEEE 802.11g ESSID:off/any Nickname:"localhost.localdomain"
    Mode:Auto Frequency:2.412 GHz Access Point: Not-Associated
    Bit Rate=54 Mb/s Tx-Power:25 dBm
    RTS thr=2347 B Fragment thr=2346 B
    Encryption key:off
    Power Management:off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    ndiswrapper version 1.23 loaded (preempt=no,smp=no)
    ndiswrapper: driver bcmwl5 (Broadcom,12/22/2004, 3.100.46.0) loaded
    ndiswrapper: using irq 217
    ndiswrapper (iw_set_bitrate:50: setting bit rate failed (C00000BB)

    wlan0: vendor: ''
    wlan0: ethernet device 00:14:a5:1e:e5:06 using NDIS driver bcmwl5, 14E4:4318.5.conf
    wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
    ADDRCONF(NETDEV_UP): wlan0: link is not ready

    ndiswrapper: driver bcmwl5 (Broadcom,12/22/2004, 3.100.46.0) loaded
    wlan0: ethernet device 00:14:a5:1e:e5:06 using NDIS driver bcmwl5, 14E4:4318.5.conf

    ndiswrapper: driver bcmwl5 (Broadcom,12/22/2004, 3.100.46.0) loaded

  8. #7
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Just an update on the situation:

    I ran these commands:

    Code:
    modprobe -r ndiwrapper
    modprobe -r bcm43xx
    modprobe ndiswrapper
    and VIOLA! the ndiswrapper(wlan0) reference is BACK in the Wireless devices diaglog box, but I cannot activate it.

    If it matters,
    I can see the ndiswrapper(wlan0), the Full Card name (Broadcom Corp. bcm......), and 'Other Cards' listed in the dialog box.

  9. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Ok I am sick and tired of this,

    If someone can help me fix this, I am willing to PAY them. This shortage has been cutting my productivity like a knife through butter, and has been testing me very much so.

  10. #9
    Just Joined! Sam Liu's Avatar
    Join Date
    Aug 2006
    Location
    USA baby
    Posts
    78
    lol its ok we'll help you through this. stick with it! dont give up!

    The activating doesnt work because you blacklisted the bcm43xx driver and it doesnt know what to do (no other driver).

    you're gonna want to try ndiswrapper again.

    hey you sure your driver is right? maybe wrong revision or something. I also heard from someone else that their card got configured as like BH instead of G. ehh I donno I'm sorta fresh, coming back to linux after 3 years of nonuse.

  11. #10
    Just Joined!
    Join Date
    Aug 2006
    Posts
    57
    Hey Thanks Sam Liu

    I currently have the bcmwl5 driver installed in ndiswrapper, but I had heard of FedoraForum that sometiems the bcm43xx driver can interfere with the ndiswrapper so I blacklisted it.

    Thanks for the help!
    And I'll be glad to make a donation in your name

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •