Find the answer to your Linux question:
Results 1 to 3 of 3
Hmmm. Despite looking through a huge number of posts and Googling til my fingers bleed, I still cannot connect if I give Squid the 'magic word(s)' in iptables. The line: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! lizardking's Avatar
    Join Date
    Aug 2006
    Location
    St-Lazare, Quebec
    Posts
    28

    Squid configure prevents everything!


    Hmmm. Despite looking through a huge number of posts and Googling til my fingers bleed, I still cannot connect if I give Squid the 'magic word(s)' in iptables.

    The line:

    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

    prevents all access.

    If the above line is commented out, lotsa access!

    A little hint please?

    Setup:
    A bunch of computers---router---eth1-Squid and firewall box (Linux)-eth0---Internet
    Thanx in advance!

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3
    Quote Originally Posted by lizardking
    The line:

    iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

    Setup:
    A bunch of computers---router---eth1-Squid and firewall box (Linux)-eth0---Internet
    It seems to me that you are trying to setup a transparent proxy, I guess to forbid access to some URLs.

    If that's the case, please first check your squid is running ok by configuring manually the proxy settings in a computer inside your LAN.
    If this works correctly, the above "iptables..." line should get you working without problems.
    Remember that if you have squid authentication enabled this scheme (transparent proxy) doesn't work.

    Hope this helps.

  3. #3
    Just Joined! lizardking's Avatar
    Join Date
    Aug 2006
    Location
    St-Lazare, Quebec
    Posts
    28

    Red face

    kaneda:

    Thanx for the quick response. The one word in your post, 'transparent', triggered a landslide in my head and I now have squid up, running and doing what I expect. (non-transparent) Looking back, I shoulda thought of it a little more.

    Thanx again, keep your stick on the ice!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •