Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Win XP to Samba networking

    Hi All

    This is my first attempt at seeking help through Linuxforums.

    Last week, I took the plunge and loaded Debian onto a P4 2.8GHz PC I had spare in order to play with Linux for the first time. All has gone well. I have managed to load a driver for the video card, sorted out errant screen resolutions and then turned my attentions to Samba. I have managed to set it up so that I can see and connect to my Windows XP PCs from my Debian PC but am having difficulty achieving the reverse i.e. connecting to the Linux PC from the Win XP machines. Having read a variety of help files and poached from a variety of sources, I have come up with a smb.conf file as follows:

    workgroup = CATRIONA
    server string = %h server (Samba %v)
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    security = share
    encrypt passwords = true
    passdb backend = tdbsam guest
    obey pam restrictions = yes
    invalid users = root
    passwrd program = usr/bin/passwd %u
    socket options = TCP_NODELAY

    [shared files]
    comment = Shared Files
    path = /home/shared files
    writable = yes
    guest ok = yes

    comment = Home Directory
    browseable = yes
    writable = yes
    create mask = 0775
    directory mask = 0775

    The result of this file's settings is that when I look in "My Network Places" on my XP machines, I can see the Samba Server icon. Sor far so good

    When I click on the icon, I see three more icons labelled "Home", "Shared files" and "Printers and Faxes"

    Clicking on the "Home" icon brings up a Windows login box with the Username already filled in with "Guest" (which is greyed out and can't be changed) and the password line available for an entry. Unfortunately, I don't know what password I should use for "Guest"

    Clicking on the "Shared" icon results in the windows generic error message stating that "\\(Server Name)\shared files is not accessible. You might not have permission to use this network resource. etc etc ..."

    Clicking on the "Printers and Faxes" icon opens Printers and Faxes directory (which is empty as I haven't got to installing printers - yet!)

    So, how do I make my home directory accessible to the Win XP machines? I currently only have one user set up on the Linux box (in addition to "root") User Name is tom.

    Likewise, What is the reason for the "shared files" error message?

    I have reached the end of my intelectual limits with this, having consulted every text I could find during the last two days. I suspect the answer is a very simple one and that I have missed it somewhere along the line.

    Can anyone help?


  2. #2
    The first thing I would suggest is have you set up a samba user? Even though you have tom as another user for the box, tom has to be set up for samba also. If you dont then you wont be able to access. That was my first problem.
    The second thing I found was that if I set my shares to Read only = No I was able to access them.
    Also I once read somewhere that sharing home directories doesnt always work very well, that may be a myth but I know when I tried it didn't work.
    I found that the best tool for working with Samba was SWAT. It made it ten times easier to administer users, shares and pretty much everything. I highly reccomend it.
    Hope this helps if not sorry!

  3. #3

    this might help


    found this great tutorial. it might help


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts