Find the answer to your Linux question:
Results 1 to 5 of 5
I'm having trouble getting my windows machine to telnet onto my new Linux box (Redhat 9.0). (trouble = spending many hours doing very little and smacking my head off the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3

    Local Network Problems.


    I'm having trouble getting my windows machine to telnet onto my new Linux box (Redhat 9.0). (trouble = spending many hours doing very little and smacking my head off the desk repeatedly)

    I can successfully ping the IP address from each machine, but telnet just sits at connecting for a while...then replies with a "Could not open connection to the host, on port 23: Connect failed".

    I've modified the /etc/xinetd.d/telnet file with :-
    disable = no, and only_from 192.168.0.0/24

    chkconfig --list shows telnet to be on

    netstat shows telnet on port 23 listening via xinetd

    I've tried to telnet from another user on the Linux machine to itself, and that works.

    In iptables I've added a line to accept anything from 192.168.0.0/24

    hosts.allow and host.deny in /etc have no entries in them, but I'm assuming iptables takes care of this area.

    Since I'm very new to Linux I'm assuming I've missed something really obvious...any help would be much appreciated.

  2. #2
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Try ssh maybe RH wont let you use Telnet now all distros should get rid of it IMO

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3
    Thanks for the reply. I've tried ssh using PuTTy. I'm aware that ssh has much better security, I was just trying to get a simple telnet connection working first before I shelved it in favour of ssh.

    Telnet did in fact work running it from a different user on the the Linux box...telnet'ing to itself. I just can't get it to work form my XP Pro machine, or a win98 machine.

    Using PuTTy, I get no feedback except for a Connection reset by peer box. So at present I've just been trying the telnet command from the command prompt.

  4. #4
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    My guess would be one of 2 things:
    1) The machine you are connecting FROM is not in the 192.168.0.x IP range
    2) The firewall is STILL blocking access by DROP'ing incoming packets - i suspect this by what you said about the delay.

    iptables firewall rules are processed in order, so if the first rule says drop anything inbound for port 23, NOTHING further down the iptables script could re-allow access to this port. That would be the thing to check IMO.

    Jason

  5. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3
    Your right Jason, option 2 it is.

    The line was in the right place, it was just that I had 1 character incorrect, which resulted in it ignoring the IP addresses I specified, and applying a later rule to reject all new connection requests.

    telnet and ssh are now working fine...thanks for your help

    Now on to really buggering things up by changing all IP address to the 10.128.128 range, setting my linux machine to route my ADSL, and provide dhcp.... how hard can that be...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •