Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, The following describes my current system setup, from which I'm getting very poor networking performance quite often. Machine: IBM Thinkpad T30 Laptop Card: IBM High Rate Wireless Mini ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    Piss-poor networking performance with 2.6 kernel


    Hi all,

    The following describes my current system setup, from which I'm getting very poor networking performance quite often.

    Machine: IBM Thinkpad T30 Laptop
    Card: IBM High Rate Wireless Mini PCI Adapter
    Distro: Gentoo
    Kernel: 2.6.17-suspend2-r2 (built using genkernel)
    Driver: orinico_pci module (built with kernel using genkernel)

    Poor performance in my case is that I can usually load small webpages like Google just fine, but trying to load pages of any substantial size will generally only half load and then just sit busy for eternity. If I get lucky, sometimes it will load the entire page, but this is usually only after multiple abort and restarts.

    This poor performance is intermittent. When things are working they seem to work fine, but that's only maybe 20% of the time.

    I get no kernel error messages (dmesg) from my wireless card.

    At first I thought it was just due to excessive network congestion, but my brother gets fine performance using Windows XP at the same time I'm having all sorts of problems and he is also using a wireless card.

    The odd thing is that when I boot in with a Live USB Pendrive (DSL or Damn Small Linux) I have perfect performance. The DSL is using a 2.4 Debian based kernel and the orinoco_pci driver also.

    I've Googled all over to see if I could solve this on my own, but I'm coming up empty and am getting quite frustrated. I've tried setting window scaling to various values with no real difference (/proc/sys/net/ipv4/tcp_window_scaling). I've tried enabling disabling ECN (/proc/sys/net/ipv4//tcp_ecn) with no results.

    I've tried using ethereal/wireshark. I get several "TCP Previous segment lost," "TCP Dup ACK," "TCP Retransmission," "TCP Window Update" packets. The only unusual one of these seems to be the "TCP Dup ACK," but I get this even when things are good.

    The most suspicious is a SYN, SYN/ACK, and then RST sequence, but I have no idea what's causing this.

    I'm at wits end and really hope someone here has seen and knows how to fix the problem(s) causing these symptoms. TIA

    John Peterson

  2. #2
    Linux User
    Join Date
    Aug 2006
    Location
    Croydon, PA
    Posts
    392
    I think it may be the card, it is rated as follows:

    Up to 11 Mbps data rate with fallback to 5.5, 2, and 1 Mbps

    Kind of slow. most cards now a days are rated at 54Mbps or more.

    Check your ethtool settings (ethtool eth<# for wireless card>) and if autoneg is on turn it off.
    I don't have wireless but this is my NIC card:

    [root@linux4 ~]# ethtool eth0
    Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 32
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: d
    Current message level: 0x00000007 (7)
    Link detected: yes

    Notice the "Auto-negotiation: on" you want that off. It may help.

    Good Luck,
    Ski

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2
    1 Mbps will not be a bottleneck if all you are doing is browsing the internet. It's not like I need to do full screen video feeds or anything crazy.

    The auto negotiation seems to only be an attribute of my wired card. This is the ethtool output of my wireless card:

    Settings for eth1:
    Link detected: yes

    That's it. Thanks anyhow.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •