Find the answer to your Linux question:
Results 1 to 5 of 5
The problem is that if I connect directly to the Comcast modem the internet works fine. But when I connect thorough the WRT54g router, the network is not working. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    15

    Network through router not working


    The problem is that if I connect directly to the Comcast modem the internet works fine. But when I connect thorough the WRT54g router, the network is not working. I tried using automatic configuration and static IP address. Under windoes XP evertything works fine. Will I have to upload some special firmware to my router so that it works on linux as well. The firewall is off.

  2. #2
    Just Joined!
    Join Date
    Dec 2005
    Posts
    54
    I have comcast err.. time warner.. whatever.. and that exact router and I found with my modem that I have to unplug it, push in the reset button and hold, then plug back in, then release rest button to manually reset the cable modem.
    The reason for this I guess is that there modems register the MAC address of the ethernet card and then wont allow a different one to connect - just a guess but this is what I do to switch my modem between my computer and router when neccesary.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    15
    But you see, I have both LInux and Windows on one machine. So I can run only one system at a time. In the router configuration I have check "Clone PC's MAC address. So when I run linux it is using the same Ethernet address since it is on the same machine. Unless in Linux it's different.

  4. #4
    Just Joined!
    Join Date
    Dec 2005
    Posts
    54
    It would be the same mac address. Like I said, that was just a guess as to why I couldnt get the modem to work with any other network card.

    Have you tried reseting the modem yet? Make sure the router is set to recieve a dhcp address from the modem, and it needs to be set to act as a dhcp server for the machines connecting to it.

  5. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    Question

    I have NO Internet connection on my Linux Desktop Dell running RH9, laptop Compaq Armada m 700, and my Toshiba laptop dual-boot with RH-9 and WinXP.
    However, when I ran WinXP on the Toshiba laptop w/ dual boot, I have the connection.

    I dual-boot the RH9 Linux for the Toshiba laptop with direct connection to the Comcast Cable modem and still no Internet connection. However, if I login as root user and checked the Network dialog. It reported the ip address.

    Should I get a new Cable Modem???

    Ricktran

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •