Find the answer to your Linux question:
Results 1 to 5 of 5
halo...i am using fedora core 4, 2.6.11-1.1369_FC4 i686 and i want to install a tool called iperf which is used to measure network performance, such as ttcp, exist, most are ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    70

    iperf for fedora core 4


    halo...i am using fedora core 4, 2.6.11-1.1369_FC4 i686
    and i want to install a tool called iperf which is used to measure network performance, such as ttcp, exist, most are very old and have confusing options.
    I did found a link as below:
    http://dast.nlanr.net/Projects/Iperf/

    May i know the package i should download is unix / win32?
    Because when i looked on the installation guide inside the downloaded package, the content as below:

    $Id: INSTALL,v 1.2 2002/10/04 22:33:06 jdugan Exp $

    Platform Specific Notes

    FreeBSD

    If you use a cc or c++ other than the system one, threads may not be
    detected properly. To work around this set the following environment
    variables:

    setenv CC /usr/bin/cc
    setenv CXX /usr/bin/c++



    This package seem like is for distribution of FreeBSD.

    May I know can I install it into fedora core 4??


    or I did found a link as below:
    http://64.233.167.104/search?q=cache...y&ct=clnk&cd=3

    But the package is for Fedora Core 4 for i386 (fc4-i386),
    but my kernel is fc4, 2.6.11-1.1369_FC4 i686

    Can i install it ??

  2. #2
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    I reckon you need a proper Linux binary file or you can install it from sources.

    Isn't there a package like "iperf-1.7.0.-source.tar.gz", e.g.?

    With such a file you should be able to install it from sources using "./configure", "make", and "make install".

    There are also ttcp and netperf, and I think, netperf installs the easiest way as it's not dependant on others libraries, packages, or the like.

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    70
    halo... i did tried to installed the "iperf-1.7.0.-source.tar.gz", but it seem like is for FreeBSD when i read the installation guide from the package. But i did tried to installed it in my fedora, i did have an error message when come to step "make" :


    [root@localhost iperf-1.7.0]# make
    Makefile:124: VERSION: No such file or directory
    make: *** No rule to make target `VERSION'. Stop.



    Did anyone know why got this problem ?? please drop your messages here . Thanks !!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Those source tarballs should be for every unix/linux/bsd platform.

    Did you run "./configure" within the expanded (from the tarball) iperf directory?

    Differences in the source code should be handled by the make file. The necessary info about your system is gained by running "configure".

    If you look at line 124 of the make file, maybe you can spot what's wrong with the constant VERSION.

    Maybe the source is only for Linux up to version 2.4?

    I'm now at home where I run FreeBSD, but at work I installed iperf a year or so ago on RedHat Linux version 2.4.

    If you could also use netperf, try this. The source is smaller and doesn't depend on other packages. I could install netperf also on a board running a MIPS processor and Linux version 2.4, but iperf and ttcp I couldn't install on this board.

    If not check what this VERSION is in the make file line 124 and/or check what the iperf Web site says to Linux 2.6. Maybe it doesn't work anymore with Linux 2.6 as those benchmark programs use low-level system ressources and significant things have changed from the transition of 2.4 to 2.6.

  6. #5
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    I just had a look at the line 124 in the make file.

    The string VERSION is actually a file name and not a constant as I thought before.

    If the file VERSION (strange name really) hasn't been found, you are presumably not within the directory "iperf-1.7.0".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •