I could have this in the wrong section but I wasn't sure where to put it. Sorry if it is.

When I ever I trie to modprobe ndiswrapper to get my wireless card to work I get an error message.

Code:
debian:/home/rusty# modprobe ndiswrapper
FATAL: Error inserting ndiswrapper (/lib/modules/2.6.15-1-486/misc/lib/modules/2.6.15-1-486/misc/ndiswrapper.ko): Invalid module format
I could realy use some help on this one. I'm running Debian Etch.

This part of the dmesg might be useful as well.
Code:
ndiswrapper: version magic '2.6.15-1-486 486 gcc-4.1' should be '2.6.15-1-486 486 gcc-4.0'
If any more imformation is needed I would be glad to provide.

P.S. I had Debian Etch installed with ndiswrapper installed and never got this error for some time. It was not untill I tried to reinstall debian that this error showed up.