Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    /etc/network/interfaces wvdial method

    I am using wvdial to connect and that works fine but I need to activate my internet connection on bootup. Apparently, the file in /etc/network/interfaces is supposed to do that automatically but does not.

    my interfaces file looks like this:

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    # The loopback network interface
    auto lo
    iface lo inet loopback
    iface ppp0 inet ppp
    provider ppp0
    can anyone tell me the correct syntax to edit the file for the wvdial method??

    I googled and checked the man pages for interfaces network, which handles the ifup and ifdown commands. I was told that any connection setup in /etc/network/interfaces with auto will be brought up on boot automatically. If I replace 'lo' with wvdial would that be the corrrect syntax????

    Anyone have the same problem getting internet connect at boot up?

  2. #2
    Well I solved this myself..I guess age and experience counts for something

    the correct syntax is

    auto lo
    iface lo inet wvdial
    provider defaults
    the term after 'inet' is where the iface address method belongs. In my case it is Wvdial since that is what I use. Other methods are ppp, manual, static ip address etc... the item after provider is the option telling iface where to find the dial up config file.

    Now when I boot up, the internet connects and allows my users internet access without the fuss or bother of a gui.

    sysop bump my ranking to something better than 'newbie' thnks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts