Find the answer to your Linux question:
Results 1 to 9 of 9
I have install pptpconfig for connet to windows VPN server through a LAN. I have centOS 4.3 and with kernel 2.6.17.11 but this error apear: pptpconfig: debug information dump begins ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    8

    VPN connection


    I have install pptpconfig for connet to windows VPN server through a LAN.
    I have centOS 4.3 and with kernel 2.6.17.11 but this error apear:

    pptpconfig: debug information dump begins
    WARNING: security sensitive information follows
    pptpconfig 1.2 2004/06/19 08:57:15
    # pppd --version
    pppd: error while loading shared libraries: libpcap.so.0.6.2: cannot open shared object file: No such file or directory
    # uname -a
    Linux linux.rayaneh.com 2.6.17.11 #1 Fri Sep 8 17:35:26 IRDT 2006 i686 i686 i386 GNU/Linux
    # grep mppe /proc/modules
    # modinfo ppp_mppe
    filename: /lib/modules/2.6.17.11/kernel/drivers/net/ppp_mppe.ko
    author: Frank Cusack <fcusack@fcusack.com>
    description: Point-to-Point Protocol Microsoft Point-to-Point Encryption support
    license: Dual BSD/GPL
    alias: ppp-compress-18
    version: 1.0.2
    vermagic: 2.6.17.11 mod_unload 686 REGPARM 4KSTACKS gcc-3.4
    depends: ppp_generic
    srcversion: 6B88E623CA7C4D7FE2F11FA
    Array
    (
    [name] => golzari
    [server] => 10.1.10.10
    [domain] =>
    [username] => golzari
    [password] => (hidden by pptpconfig)
    [pppd-options] => nopcomp noaccomp require-pap
    [pptp-options] =>
    [resolv] =>
    [dns-options] =>
    [routing] => routing_client_to_lan
    [usepeerdns] => 1
    [require-mppe] => 1
    [nomppe-40] => 1
    [nomppe-128] => 1
    [refuse-eap] => 1
    [mppe-stateful] => 1
    [autostart] =>
    [iconify] =>
    [persist] =>
    [debug] => 1
    [client-to-lan] =>
    )
    # route -n (before pppd)
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
    10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
    pptpconfig: debug information dump ends, starting pppd
    /usr/sbin/pppd: error while loading shared libraries: libpcap.so.0.6.2: cannot open shared object file: No such file or directory
    # route -n (after pppd exit)
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
    10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
    pptpconfig: pppd process stopped by signal 0 (started)
    ip route add 10.1.10.10 via 10.1.13.1 dev eth1 src 10.1.13.93
    RTNETLINK answers: File exists

    pptpconfig: command failed, exit code 2
    pptpconfig: routes added to remote networks
    pptpconfig: usepeerdns was set, but /{var/run,etc}/ppp/resolv.conf was not readable
    pptpconfig: connected
    # route -n (after completion)
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
    10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
    -------------------------
    I realy wanna help to resolve this problem.

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    pppd: error while loading shared libraries: libpcap.so.0.6.2: cannot open shared object file: No such file or directory
    I haven't used CentOS, but I'm sure it must have an RPM named libpcap0. Installing it should solve this.

    BTW, for my VPN I prefer OpenVPN. There are versions for both GNU/Linux and Windows. CentOS might even have an RPM.

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    8

    vpn connection

    Quote Originally Posted by KenJackson
    I haven't used CentOS, but I'm sure it must have an RPM named libpcap0. Installing it should solve this.

    BTW, for my VPN I prefer OpenVPN. There are versions for both GNU/Linux and Windows. CentOS might even have an RPM.
    hi,thanks for ur attention.
    but I already have libpcap,and I upgrade it.
    ???????????

  4. #4
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    OK, I see that my version of libpcap (on Mandriva) has file /usr/lib/libpcap.so.0.9, not 0.6.2. Yours is probably similar.

    pptpconfig 1.2 2004/06/19 08:57:15
    Is this the most recent version you can find?

    I think there are three possible solutions.
    • Find a more recent version of pptpconfig,
    • Find an older version of libpcap,
    • Or do the following to see if it satisfies the version you have. (Sometimes this works perfectly.)


    Code:
    cd /usr/lib
    ln -s libpcap.so.0.9 libpcap.so.0.6.2
    You have to do that as root, of course. It will create a symbolic link which pptp will find and use. The only problem will be if there are binary incompatibilites between the two libpcap versions for any of the functions used by pptp. Just try it and see if there are any problems.

    Also, if you don't have libpcap.so.0.9, then change the command to match what you have.

  5. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    8

    thanks,but...

    hi and thanks for it.that problem was solved,but another one appear:
    when start the connection:::
    -----
    pptpconfig: debug information dump begins
    WARNING: security sensitive information follows
    pptpconfig 1.2 2004/06/19 08:57:15
    # pppd --version
    pppd version 2.4.3
    # uname -a
    Linux linux.rayaneh.com 2.6.17.11 #1 Fri Sep 8 17:35:26 IRDT 2006 i686 i686 i386 GNU/Linux
    # grep mppe /proc/modules
    # modinfo ppp_mppe
    filename: /lib/modules/2.6.17.11/kernel/drivers/net/ppp_mppe.ko
    author: Frank Cusack <fcusack@fcusack.com>
    description: Point-to-Point Protocol Microsoft Point-to-Point Encryption support
    license: Dual BSD/GPL
    alias: ppp-compress-18
    version: 1.0.2
    vermagic: 2.6.17.11 mod_unload 686 REGPARM 4KSTACKS gcc-3.4
    depends: ppp_generic
    srcversion: 6B88E623CA7C4D7FE2F11FA
    Array
    (
    [name] => golzari
    [server] => 10.1.10.10
    [domain] =>
    [username] => golzari
    [password] => (hidden by pptpconfig)
    [pppd-options] => nopcomp noaccomp require-pap
    [pptp-options] =>
    [resolv] =>
    [dns-options] =>
    [routing] => routing_client_to_lan
    [usepeerdns] => 1
    [require-mppe] => 1
    [nomppe-40] => 1
    [nomppe-128] => 1
    [refuse-eap] => 1
    [mppe-stateful] => 1
    [autostart] =>
    [iconify] =>
    [persist] =>
    [debug] => 1
    [client-to-lan] =>
    )
    # route -n (before pppd)
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
    10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
    pptpconfig: debug information dump ends, starting pppd
    pppd options in effect:
    debug # (from /etc/ppp/peers/golzari)
    updetach # (from command line)
    logfd 1 # (from command line)
    linkname golzari # (from /etc/ppp/peers/golzari)
    dump # (from /etc/ppp/peers/golzari)
    require-pap # (from /etc/ppp/peers/golzari)
    refuse-chap # (from /etc/ppp/options.pptp)
    refuse-mschap # (from /etc/ppp/options.pptp)
    refuse-eap # (from /etc/ppp/options.pptp)
    name golzari # (from /etc/ppp/peers/golzari)
    remotename golzari # (from /etc/ppp/peers/golzari)
    # (from /etc/ppp/options.pptp)
    pty pptp 10.1.10.10 --nolaunchpppd # (from /etc/ppp/peers/golzari)
    noaccomp # (from /etc/ppp/peers/golzari)
    nopcomp # (from /etc/ppp/peers/golzari)
    ipparam golzari # (from /etc/ppp/peers/golzari)
    usepeerdns # (from /etc/ppp/peers/golzari)
    nobsdcomp # (from /etc/ppp/options.pptp)
    nodeflate # (from /etc/ppp/options.pptp)
    # (from /etc/ppp/peers/golzari)
    # (from /etc/ppp/peers/golzari)
    require-mppe-128 # (from /etc/ppp/options.pptp)
    nomppe-128 # (from /etc/ppp/peers/golzari)
    mppe-stateful # (from /etc/ppp/peers/golzari)
    using channel 1
    Using interface ppp0pptpconfig: monitoring interface ppp0

    Connect: ppp0 <--> /dev/pts/2
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap> <magic 0xefcc3528>]
    rcvd [LCP ConfReq id=0x0 <auth pap> <magic 0x71e118c7> <pcomp> <accomp> <callback CBCP> <mrru 1614> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13 .9d.00.00.00.00]> < 17 04 08 73>]
    sent [LCP ConfRej id=0x0 <pcomp> <accomp> <callback CBCP> <mrru 1614> < 17 04 08 73>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <auth pap> <magic 0xefcc3528>]
    rcvd [LCP ConfReq id=0x1 <auth pap> <magic 0x71e118c7> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13 .9d.00.00.00.00]>]
    sent [LCP ConfAck id=0x1 <auth pap> <magic 0x71e118c7> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13 .9d.00.00.00.00]>]
    sent [PAP AuthReq id=0x1 user="golzari" password=<hidden>]
    rcvd [PAP AuthAck id=0x1 ""]
    PAP authentication succeeded
    rcvd [LCP ConfReq id=0x3 <auth pap> <magic 0x13a65e4> <pcomp> <accomp> <callback CBCP> <mrru 1614> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13 .9d.00.00.00.00]> < 17 04 08 73>]
    sent [LCP ConfReq id=0x2 <asyncmap 0x0> <auth pap> <magic 0x8a8aae30>]
    sent [LCP ConfRej id=0x3 <pcomp> <accomp> <callback CBCP> <mrru 1614> < 17 04 08 73>]
    rcvd [LCP ConfRej id=0x2 <auth pap>]
    sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x8a8aae30>]
    rcvd [LCP ConfReq id=0x4 <auth pap> <magic 0x13a65e4> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13 .9d.00.00.00.00]>]
    sent [LCP ConfAck id=0x4 <auth pap> <magic 0x13a65e4> <endpoint [local:c4.22.99.55.70.41.4d.1a.9c.ac.b4.f3.d1.97.13 .9d.00.00.00.00]>]
    rcvd [LCP ConfAck id=0x3 <asyncmap 0x0> <magic 0x8a8aae30>]
    peer refused to authenticate: terminating link
    sent [LCP TermReq id=0x4 "peer refused to authenticate"]
    rcvd [LCP TermAck id=0x4 "peer refused to authenticate"]
    Connection terminated.
    Waiting for 1 child processes...
    script pptp 10.1.10.10 --nolaunchpppd , pid 5460
    sending SIGTERM to process 5460
    Script pptp 10.1.10.10 --nolaunchpppd finished (pid 5460), status = 0x0
    # route -n (after pppd exit)
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
    10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
    pptpconfig: pppd process terminated by signal 11 (failed)
    pptpconfig: SIGSEGV
    # route -n (after completion)
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    10.1.10.10 10.1.13.1 255.255.255.255 UGH 0 0 0 eth1
    10.1.13.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
    0.0.0.0 10.1.13.1 0.0.0.0 UG 0 0 0 eth1
    -----------------
    ur opinion??


    Quote Originally Posted by KenJackson
    OK, I see that my version of libpcap (on Mandriva) has file /usr/lib/libpcap.so.0.9, not 0.6.2. Yours is probably similar.

    Is this the most recent version you can find?

    I think there are three possible solutions.
    • Find a more recent version of pptpconfig,
    • Find an older version of libpcap,
    • Or do the following to see if it satisfies the version you have. (Sometimes this works perfectly.)


    Code:
    cd /usr/lib
    ln -s libpcap.so.0.9 libpcap.so.0.6.2
    You have to do that as root, of course. It will create a symbolic link which pptp will find and use. The only problem will be if there are binary incompatibilites between the two libpcap versions for any of the functions used by pptp. Just try it and see if there are any problems.

    Also, if you don't have libpcap.so.0.9, then change the command to match what you have.

  6. #6
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    sent [PAP AuthReq id=0x1 user="golzari" password=<hidden>]
    rcvd [PAP AuthAck id=0x1 ""]
    PAP authentication succeeded
    That's very encouraging. You submitted your username and password and the ISP accepted you.

    peer refused to authenticate: terminating link
    I'm not certain, but I think this means that you queried the ISP computer for it's identity and it refused to identify itself. This may be because you have this:
    [pppd-options] => nopcomp noaccomp require-pap
    I would try removing require-pap and see if it works.

    pptpconfig: SIGSEGV
    That's bad news. Often it means you have the wrong library, so maybe our manual symbolic link won't work. But then again, maybe it will work as long as you don't fail pap authentication.

  7. #7
    Just Joined!
    Join Date
    Sep 2006
    Posts
    8

    thanks

    thanks and I m going to test it,but not sure.
    I completely confused.
    Quote Originally Posted by KenJackson
    That's very encouraging. You submitted your username and password and the ISP accepted you.

    I'm not certain, but I think this means that you queried the ISP computer for it's identity and it refused to identify itself. This may be because you have this: I would try removing require-pap and see if it works.

    That's bad news. Often it means you have the wrong library, so maybe our manual symbolic link won't work. But then again, maybe it will work as long as you don't fail pap authentication.

  8. #8
    Just Joined!
    Join Date
    Mar 2006
    Posts
    6
    golzari-ali: The offical pptp diagnosis documentation has nothing on those errors, except "peer refused to authenticate: terminating link", to which it advices - "Enable debug logging, try the connection again, and look for rejection packets just prior to this message. Decide what to do based on the rejection packets." .. which isn't too helpful :/

    I'm also experiencing some problems with pptp (connecting to SecureIX) and I'm using Ubuntu 6.06.1. Im trying to connect to a MS VPN server that requires authentication. From the looks of it, it looks like chap MS-V2 isn't being authenticated perhaps.
    moon@moon:sudo pon SecureIX debug dump logfd 2 nodetach
    pppd options in effect:
    debug # (from command line)
    nodetach # (from command line)
    logfd 2 # (from command line)
    dump # (from command line)
    noauth # (from /etc/ppp/options.pptp)
    name accountlogin # (from /etc/ppp/peers/SecureIX)
    remotename PPTP # (from /etc/ppp/peers/SecureIX)
    # (from /etc/ppp/options.pptp)
    pty pptp vpn.secureix.com --nolaunchpppd # (from /etc/ppp/peers/SecureIX)
    crtscts # (from /etc/ppp/options)
    # (from /etc/ppp/options)
    asyncmap 0 # (from /etc/ppp/options)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    hide-password # (from /etc/ppp/options)
    ipparam SecureIX # (from /etc/ppp/peers/SecureIX)
    proxyarp # (from /etc/ppp/options)
    nobsdcomp # (from /etc/ppp/options.pptp)
    nodeflate # (from /etc/ppp/options.pptp)
    noipx # (from /etc/ppp/options)

    Using channel 39
    Using interface ppp0
    Connect: ppp0 <--> /dev/pts/1
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x2b7af573> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x1 <mru 1408> <asyncmap 0x0> <auth chap MS-v2> <magic 0xacc4f284> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x1 <auth chap MS-v2>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x2b7af573> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x2 <mru 1408> <asyncmap 0x0> <magic 0xacc4f284> <pcomp> <accomp>]
    sent [LCP ConfAck id=0x2 <mru 1408> <asyncmap 0x0> <magic 0xacc4f284> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0x2b7af573]
    sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0>]
    rcvd [LCP TermReq id=0x3 "peer refused to authenticate"]
    LCP terminated by peer (peer refused to authenticate)
    sent [LCP TermAck id=0x3]
    Script pptp vpn.secureix.com --nolaunchpppd finished (pid 10547), status = 0x0
    Modem hangup
    Connection terminated.
    I checked out the diagnosis page for pptp (http://pptpclient.sourceforge.net/ho...th_is_possible) and it shows two possible reasons for the "No auth is possbile" error:

    1 - pppd could not find a matching entry in the chap-secrets file, (see below for causes)
    chap-secrets file:
    # client server secret IP addresses
    accountlogin password *
    Thats the info I have in there (actual info changed for postings sake).

    2 - pppd was built without MS-CHAP-V2 support (quite uncommon).
    I'm not exactly sure how to verify this :/.

    Current versions:
    pptp - v1.7.0
    ppp - v2.4.4 (came with Ubuntu 6.06.1 installation)

    I'm new to linux and would appreciate any tidbits of information you may have to offer,

    Thanks,
    Shawn

  9. #9
    Just Joined!
    Join Date
    Sep 2007
    Posts
    1
    I solved that:
    Quote Originally Posted by sm00nie View Post
    LCP terminated by peer (peer refused to authenticate)
    commenting
    Code:
    refuse-eap
    refuse-chap
    refuse-mschap
    in file /etc/ppp/options.pptp

    That is, /etc/ppp/options.pptp included the lines
    Code:
    #refuse-eap
    #refuse-chap
    #refuse-mschap

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •