Find the answer to your Linux question:
Results 1 to 2 of 2
Edited to read easier and reflect new understanding of the problem: I am trying to configure a Linksys WUSB12 wireless usb drive for my linux box running SuSE x86_64. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Aug 2005
    Posts
    408

    wireless router: really need help with this one


    Edited to read easier and reflect new understanding of the problem:

    I am trying to configure a Linksys WUSB12 wireless usb drive for my linux box running SuSE x86_64. I think the problem I am encountering is that I have not attempted to install a 64-bit version of the Linksys driver even though I installed a 64-bit version of ndiswrapper and the kernel module. It doesn't appear that a 64-bit driver exists. Should I just delete the x86_64 version of ndiswrapper that I installed and attempt to install the i586 version? Would that even work?


    Information on what I have tried and other specifics is below:

    --Installed ALL ndiswrapper listings via smart, and this apparently installed the kernel module.
    --Issued the command "ndiswrapper -i" on the two .inf files I got from Linksys: AUTORUN.INF and LSWUSB.INF.
    --ndiswrapper -l tells me:
    autorun invalid driver!
    lswlusb driver installed, hardware present

    "modprobe ndiswrapper" brings up no errors but when I check the log (and dmesg), I see the following:
    ndiswrapper: module not supported by Novell, setting U taint flag.
    ndiswrapper version 1.10 loaded (preempt=no,smp=yes)
    ndiswrapper (check_nt_hdr:149): Windows driver is not 64-bit; bad magic: 010B
    ndiswrapper (load_sys_files:213): couldn't prepare driver 'lswlusb'
    ndiswrapper (load_wrap_driver:111): loadndiswrapper failed (65280); check system log for messages from 'loadndisdriver'
    ndiswrapper: probe of 2-1:1.0 failed with error -22
    usbcore: registered new driver ndiswrapper
    "lsusb" tells me:
    Bus 002 Device 002: ID 066b:2213 Linksys, Inc. WUSB12v1.1 802.11b Adapter

    I found this information from http://www.linux-wlan.org/docs/wlan_adapters.html.gz :
    Linksys 802.11b WUSB12 mini-USB Prism2/2.5/3 Linux-wlan-ng

  2. #2
    Linux User
    Join Date
    Aug 2005
    Posts
    408
    well, that didn't work. Note to anyone else: don't bother trying to configure and install the 32-bit version of ndiswrapper on a 64-bit kernel with the intent to use 32-bit drivers. It sounds stupid like that, but it could have worked, right?

    Anyway, I think the way to go to get it to work is wlan-ng (others have done this successfully), but I think I'm just going to return the router I have and get another one that I can plug the computer directly into.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •