Find the answer to your Linux question:
Results 1 to 2 of 2
Hi: I installed SUSE 9.0 in my pc, that has a DSL connection going through eth0 (Dlink card) and is configured OK. Well, after installing, i decided to install my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    2

    Problems in SUSE 9.0 + Firebird 0.8 + Firewall


    Hi:

    I installed SUSE 9.0 in my pc, that has a DSL connection going through eth0 (Dlink card) and is configured OK.
    Well, after installing, i decided to install my prefered browser, Firebird 0.8 wich i uncompressed in one of my personal folders within my home directory.
    I was happy i could surf the net without a glitch, but i was uncomfortable about not using a firewall... sooo i decided to configure and activate the one within YAST. I used PPP0 as external and eth1 as internal (my second NIC, an integrated NVIDIA card) and didn't activate any other service (nor HTTP, or FTP, or TELNET, etc).
    Well upon activation, my browser started to become unstable: first i if pressed the toolbar buttons with my favorytes address, couldn't access any of them (looking for www.xxx.xxx forever) so i went back to firewall configuration and realized i could solve that problem by activating HTTP service. OK. Now comes the sad part: whatever are the settings i have tried in the firewall configuration, if i try to type an URL in my browser: The Browser Freezes!!!! I have to kill manually the process, and the problems repeats it every single time i have tried to type something. The only solution is turn off Firewall.

    Well: could somebody point me out for a solution for this problem?? (hopefully not involving upgrade the kernel/kde/yast as i'm pretty new to SUSE and Linux)

    Thanks in advance

    Flavio.

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    i would guess that its actually hanging on the DNS lookups from your description of the problem....

    You need to enable UDP packets to port 53.

    I have never seen the GUI thing your using, so cannot advise on how it would be done.

    In addition to this, you need to ensure that "ESTABLISHED" and "RELATED" traffic is permitted to pass, though keep inbound NEW off.

    Jason

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •