Find the answer to your Linux question:
Results 1 to 2 of 2
OK here is the problem. As root I mount the shared windows drive; mount -t smbfs //[IP]/f /mnt/nas -o username=[?],workgroup=[?] This mounts the drive fine. As root I'm able to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4

    trouble mounting a Windows drive


    OK here is the problem.

    As root I mount the shared windows drive;

    mount -t smbfs //[IP]/f /mnt/nas -o username=[?],workgroup=[?]

    This mounts the drive fine. As root I'm able to browse and edit files on this drive. great.

    However, I don't want to access this drive as root. I want to access the drive as a normal user. I can navigate to /mnt/nas and view the directories and files. However, I cannot create or delete any of the files or directories!

    I log back in as root and try a chmod 777 /mnt/nas -v

    This tells me it has worked.

    a ls -l on the other hand tells me it hasn't worked.

    How can I allow normal users to edit files on this share?

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Please dont double post. See answer on other post: here
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •