Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, hope someone can help me with this. I am having issues with getting routing between 'internal' and 'external' interfaces working. Both have non-routable IP address (eth0 192.168.1.x) (eth1 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Ip_forward Issue


    Hi all, hope someone can help me with this.

    I am having issues with getting routing between 'internal' and 'external' interfaces working.
    Both have non-routable IP address (eth0 192.168.1.x) (eth1 192.168.10.x).

    Eth0 is the external interface, it's gateway being the inside interface of the DSL router (which has the routable IP address)

    I can ping outside fine from the linux box but any hosts on the LAN 192.168.10.x cant. They can reach their gatway which is the IP address of eth1 and they can reach eth0 but they cant reach the inside interface of the router or the internet.

    I have tried playing around with adding routes, I have turned on proc/sys/net/ipv4/ip_forward and it looks like it should work but it isnt.

    Here are some configs

    ifconfig
    eth0 Link encap:Ethernet HWaddr 00:50:BA:B0:B9:16
    inet addr:192.168.1.78 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::250:baff:feb0:b916/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:22138 errors:0 dropped:0 overruns:0 frame:0
    TX packets:30811 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3387455 (3.2 MiB) TX bytes:36315004 (34.6 MiB)
    Interrupt:11 Base address:0x8000

    eth1 Link encap:Ethernet HWaddr 00:90:27:2F:62:7A
    inet addr:192.168.10.100 Bcast:192.168.10.255 Mask:255.255.255.0
    inet6 addr: fe80::290:27ff:fe2f:627a/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4923 errors:0 dropped:0 overruns:0 frame:0
    TX packets:114 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:366072 (357.4 KiB) TX bytes:8438 (8.2 KiB)
    route -n

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    192.168.10.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

    cat /proc/sys/net/ipv4/ip_forward = 1


    contents of /etc/sysconfig/network is
    NETWORKING=yes
    HOSTNAME=support.berginct.com
    FORWARD_IPV4=yes
    GATEWAY=192.168.1.1

    I have tried with and without firewall on - still no luck.

    Any help greatly appreciated.

    Regards

    Matt

  2. #2
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240
    Which distro do you have?
    Do you have a firewall? If yes routing has to be enabled between the two nics.
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2
    Thanks for your advice.

    It was a POSTROURTING command that was missing - I downloaded a firewall script (rc.firewall-2.4-stronger, added in relevant IPs and ports and it worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •