Find the answer to your Linux question:
Results 1 to 4 of 4
i'm really sorry if this doesn't belong here and i am well aware that this is a *linux* forum, but i am very desperate, and would appreciate any help, even ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    noob connecting two computers


    i'm really sorry if this doesn't belong here and i am well aware that this is a *linux* forum, but i am very desperate, and would appreciate any help, even if its just pointing me in the right direction.

    firstly i'm using windows xp pro (sorry)

    Basically i have just arrived in university and was horrified to find that a few of programs i use (ventrilo and xfire if your familiar with them) do not work through the university connection. The university, from what i understand uses a proxy.

    Now, one way i found to bypass this problem was using two programs, http-tunnel and freecap. From my understanding, together they encrypt my programs through port 80 as http to a server. This does indeed bypass the firewall, but the speed is extremely slow, and due to the nature of the programs, a good ping is needed. I do not think it is my university connection, as it is (advertised) as 10mb and seems very fast.

    regardless, what i then set out to do is connect directly to my computer at home (about an hours drive from my uni), through http, and then use my home connection for these programs.

    my computer at home is always on, and is always connected to the internet. Problem is, i have totally no idea how to connect them both, and how to tunnel the infomation to my home PC. On top of that, upon researched i came across infomation which led me to beleive my home connection does not have an ip, but is behind some kind of proxy itself, set up by my isp (i could be completely wrong, take into account i'm a moron).

    Any help would be GREATLY appreciated, as i said before, even if its just pointing me in the right direction.

    sincerely

    Miro

  2. #2
    Linux Newbie unchiujar's Avatar
    Join Date
    Oct 2006
    Posts
    194

    ssh tunneling

    Are these two programs rerouting the trafic through some other server by any chance ? That could be a reason why they are so slow.

    I would use ssh tunneling for this, and use de 80 tcp port. No server to route through, therefore faster.

    Read all about it
    http://www.ssh.com/support/documenta...Explained.html

    You'll have to figure out how to use ssh on windoze on yourself though. It might a bit more complicated than in Linux .
    For an ssh client you can use putty(google it), for servers I have no idea.

  3. #3
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240
    Depending on your requirement you might need a ssh demon on your WIN box. cygwin is very nice (linux on win!) and has a sshd demon.
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  4. #4
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2
    I have got to the stage were i have PuTTy installed on my computer here at university, and at home i have a windows box with openSSH installed.

    The problem is i can get no contact between the two computer whatsoever. I have no idea why not. I have followed this

    http://www.buzzsurf.com/surfatwork/

    guide.

    I don't know if the problem is at my university end, or my home end.

    One thing that leads me to beleive that the problem does not lie at the universitys end is that i have successfully run the free program 'HTTP-tunnel' from my university, and got programs to run via this http tunneling server.

    However i cannot get putty to connect to my server at home and i really don't know where i have gone wrong. I have forwarded the ports on my home router correctly (i think).

    Two conclusions come to mind.

    That it simply isn't possible on my home connection? I have heard of cases were users have been behind an ISP NAT server. Could this be the case? If it is the case is my cause hopeless?

    Or another idea that came to mind is that i haven't congifured PuTTy properly through my university proxy. I had to change very little on the program 'HTTP-tunnel' to get it to work, but with PuTTy i honestly feel overwhelmed with the options.

    Thanks again for your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •