Find the answer to your Linux question:
Results 1 to 5 of 5
I have been trying to sftp and scp something from home for hours without luck. I am connecting to my ssh server which has a file available on it that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225

    Scp stalled


    I have been trying to sftp and scp something from home for hours without luck. I am connecting to my ssh server which has a file available on it that I am pulling to my local machine. It takes me 15 seconds to log in via ssh using ssh keys that I have set up, but it works and I can issue commands etc... but whenever I try to pull anything, even something tiny like .bashrc it seems to stall and hang for ages.
    Code:
    somefile                          0% 4096     0.0KB/s - stalled -
    somefile                          0% 4096     0.0KB/s - stalled -
    somefile                          0% 4096     0.0KB/s - stalled -
    Nothing at all happens, the above is all I see after leaving it for half an hour trying to pull one 3-4Mb file.

    I know the connection is slow, but surely it must still work if I can log in a issue commands normally etc.

    Why does it keep stalling?

    EDIT: After about 1.5-2hours of leaving it running it now says
    Code:
    somefile                          1%   80KB   0.0KB/s - stalled -

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,892
    Have you tried using scp with the '-v' option - this turns on verbose/debug output. It might give a few clues.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I have a few problems with scp, generally it will stall when I start surfing the net during a file transfer but I run a wireless network and I am convinced this is the cause. Bandwidth is tight on the network.

  4. #4
    Just Joined! cuervo73's Avatar
    Join Date
    Apr 2006
    Posts
    47

    Re: Scp stalled

    if it ALWAYS stalls, it might be your firewall. If you have iptables turned on, do you have the iptables FTP connection tracking module loaded? If that is missing, then it will not work thru the firewall rules.

    modprobe ip_conntrack_ftp

    also

    modprobe ip_nat_ftp

    cuervo

  5. #5
    Linux Newbie humbletech99's Avatar
    Join Date
    Nov 2005
    Posts
    225
    no, sftp doesn't use this since it doesn't jump ports the way regular ftp does. Also, I don't have a host firewall, only a gateway firewall which should allow the established connection back in by default nat behavior.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •