Hello, I just managed to pass the first hurdle and get the VPN connected, using pptpconfig. Now I'm trying to actually mount a samba share over the vpn but smbclient is just giving me timeouts on both the ports it tries, although I can ping the host successfully.

If I stopped the pptp connection I got the same result so I tried making net.ppp0 (some of this might be gentoo specific) service with

Code:
config_ppp0=( "ppp" )
link_ppp0="eth0"
plugins_ppp0=( "pppoe" "winbind" )
username_ppp0="me"
and various restarts of ppp0 and eth0 and still getting the same timeout result, so I'm not sure if smbclient should be trying to connect through ppp0, and if it's not could that be the problem?

Thanks, Dom.

smb.conf
Code:
[global]

   workgroup = MYVPN
   server string = Samba Server %v
   log file = /var/log/samba/log.%m
   max log size = 50
   hosts allow = 127.
   map to guest = bad user
   security = user
   encrypt passwords = yes
   socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
   dns proxy = no 

[homes]
   comment = Home Directories
   browseable = no
   writable = yes

[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = yes
   writable = no
   printable = yes
   create mode = 0700

[print$]
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   write list = @adm root
   guest ok = yes