Find the answer to your Linux question:
Results 1 to 3 of 3
alright well i have a dlink dwl-g630 and a hp broadcom4318 airforce one 54g, and i have tried ndiswrapper on the dlink, and when i tried to install the drivers ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    98

    suse 10.1, 2 cards neither work


    alright well i have a dlink dwl-g630 and a hp broadcom4318 airforce one 54g, and i have tried ndiswrapper on the dlink, and when i tried to install the drivers the computer still didnt recognize it(there were no errors while i was running ndiswrapper), and i found the drivers for my broadcom one but it was in a exe form and i dont know how to get the .inf file or w/e it is i need, through yast->hardware-info i am able to see that my computer recognizes that the broadcom chip is there though, on suse 10 the dlink card was setup automaticaly, so i was wondering if there is something like that i could use for suse 10.1, but any help would be much appreciated

  2. #2
    Just Joined! cuervo73's Avatar
    Join Date
    Apr 2006
    Posts
    47

    Re: suse 10.1, 2 cards neither work

    first off, does the SuSE 10.1 kernel have 8K stacks enabled? If not, then ndiswrapper will not work with that kernel [after you modprobe/insmod it]. You will have to build a new kernel, and turn off 4K stacks [thus enabling 8K]. This setting is down under Kernel Hacking in the Xconfig GUI. The old SuSE 10 kernel must have been compiled for 8K stacks, so it worked for you there.

    For your Broadcom NIC, same problem..

    When you get the 8K stack kernel built & booted/loaded, then you can do this for the windoze driver loads:

    cd /directory/the/winXP/drivers/are/in
    ndiswrapper -i the.inf.filename

    That will read the .inf file, and load the correct driver .exe files into the directory
    /etc/ndiswrapper/driver-name/

    then, run modprobe ndiswrapper

    This will load the wrapper module into the kernel. you can check in /var/log/messages logfile by running: dmesg | grep ndiswrapper to see if things were loaded OK.

    cuervo

  3. #3
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    I had problems with Suse not detecting my wireless cards. I had to edit the kernel parameters section in /boot/grub/menu.lst and add the line "pci=assign-busses" then reboot. After this all pcmcia wireless cards were detected even without the drivers being installed.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •