Find the answer to your Linux question:
Results 1 to 2 of 2
I am attempting to get waproamd to work. After playing around a few hours I can now get waproamd to fire off a script when it associates with an access ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3

    Odd network problem


    I am attempting to get waproamd to work. After playing around a few hours I can now get waproamd to fire off a script when it associates with an access point. It pulls the correct information from files and sets wlan0 accordingly. Here is the odd thing when waproamd fires up on boot it associates and uses dhcp to get an ip. It gets an IP just fine via using dhclient. But when I try to access the network I get problems with there being no route to host.


    The commands the script runs are the following

    ifconfig wlan0 down
    iwconfig wlan0 key open ##########
    iwconfig wlan0 essid $$$$$$$
    iwconfig wlan0 ap any
    ifconfig wlan0 up
    dhclient -q wlan0

    I have also tried

    dhclient -r
    iwconfig wlan0 key open ##########
    iwconfig wlan0 essid $$$$$$$
    iwconfig wlan0 ap any
    ifconfig wlan0 up
    dhclient -q wlan0

    If I run these scripts after I login or I restart waproamd it works fine. But on boot it fails to work.

    running route shows the route but the last entry hangs. Finally after 30 seconds it shows up fine. Every time i run route this happens. If i run my script to reset up the network then run route it comes up instantly.

    I have tried removing and readding the default route but it still has the same problems.


    is dhclient -r the best way to release an IP so I get a new one?

    I just tried out linux while at a different wirless network and it came up just fine. So i'm thinking I need to add a flag to the dhclient but i'm unsure. At home i'm on a lynksys accesspoint.

    Anyone have any suggestions on why I am gettings no route to host until I rerun the script?

  2. #2
    Just Joined!
    Join Date
    Mar 2004
    Posts
    3
    More info:

    I tried to make the script run 2 minutes after the system booted up. It ran just fine but still I got no route to host errors.

    So next I tried to make the script execute as a shell login script. I touched a file and deleted it on shutdown so that only the first login would cause the script to run.

    Still I had the same problems.

    So it seems like there is some sort of problem with automated scripts. Is there some varaible set when a script is executed by hand versus by an login or startup script?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •