I am unable to connect the LG LSI 110 to internet using Fedora Core 5. It is connected via USB cable. Below are the outputs and contents
or various files, Please have a look and see where I am wrong .

dmesg output

drivers/usb/class/cdc-acm.c: v0.25:USB Abstract Control Model driver for USB modems and ISDN adapters
usb 2-1: USB disconnect, address 2
usb 2-1: new full speed USB device using uhci_hcd and address 3
usb 2-1: configuration #1 chosen from 1 choice
cdc_acm 2-1:1.0: ttyACM0: USB ACM device

Contents of wvdial.conf

[Dialer Defaults]
Modem = ttyACM0
Baud = 115200
Init1 = AT+crm=1;$LGPKT=3
ISDN = 0
Modem Type = Analog Modem
Phone = #777
Username = 1813206900
Password = 1813206900
Stupid Mode = 1


Contents of /etc/ppp/peers/rconnect

asyncmap 0
connect '/usr/sbin/chat -v "" at+crm=1 OK "atdt#777" CONNECT'
mtu 264
name reliance
user 1813206900
Output of the command "wvdial rconnect"

--> WvDial: Internet dialer version 1.54.0
--> Warning: section [Dialer rconnect] does not exist in wvdial.conf.
--> Cannot open ttyACM0: No such file or directory
--> Cannot open ttyACM0: No such file or directory
--> Cannot open ttyACM0: No such file or directory

Below is the output of the rconnect script by Reliance

[STEP : 5 ] Connecting to internet using R Connect

Making a Connection

<Username>/<Password>-Enter your phone number with the STD code prefixed to it
[Example: 2231790000]

Please enter Username : 1813206900
Please enter Password :
Connecting to Device.........
pppd: unrecognized option '/dev/usb/ttyUSB0'
pppd version 2.4.3
Usage: pppd [ options ], where options are:
<device> Communicate over the named device
<speed> Set the baud rate to <speed>
<loc>:<rem> Set the local and/or remote interface IP
addresses. Either one may be omitted.
asyncmap <n> Set the desired async map to hex <n>
auth Require authentication from peer
connect <p> Invoke shell command <p> to set up the serial line
crtscts Use hardware RTS/CTS flow control
defaultroute Add default route through interface
file <f> Take options from file <f>
modem Use modem control lines
mru <n> Set MRU value to <n> for negotiation
See pppd( for more options.

================================================== =================