Find the answer to your Linux question:
Results 1 to 7 of 7
I have two pcs with RHEL installed and both connected with crossover cable. ethernet interface is defined as eth0 on each pc. ip address has been assigned statically one is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8

    linux machines using crossover cable


    I have two pcs with RHEL installed and both connected with

    crossover cable.

    ethernet interface is defined as eth0 on each pc.

    ip address has been assigned statically

    one is 192.168.0.1 other is 192.168.0.2

    ifconfig responds on both pcs however when i try to ping one

    from other i get no reply

    firewall is turned off on both and the /etc/hosts file has also

    been defined on both

    Do I have to configure DHCP? or do I have to define a gateway

    in the routing table

    Please help

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    45
    What's the netmask and broadcast for each interface? Those have to match. Since a crossover is being used routing isn't a factor.

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8

    here are the details

    The netmask is 255.255.255.0 and broadcast address is 192.168.0.255 for both.


    I was doubting that network address is not needed as there is no router here, thx for the clarification.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    45
    Appears network is correct. Have you checked the cable? Check that you have link light on both NIC's.

  6. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8

    checked it

    I tried the foll on first comp
    # route add -host (ip of second comp) gw(ip of first comp) dev eth0
    and tried to ping second comp from first comp .No joy.



    I checked the connection using mii-too -v , the link is showing as autonegotiation enabled on one and no link on the other pc.

    Maybe thts the problem

    But Im wondering why is it happening in linux and not in windows

  7. #6
    Just Joined! cuervo73's Avatar
    Join Date
    Apr 2006
    Posts
    47

    Re: linux machines using crossover cable

    nbodiju,

    The PC which doesn't have the link LED on.. maybe the driver for that NIC isn't loaded.. try lsmod and check that the NIC driver is loaded.

    cuervo

  8. #7
    Just Joined!
    Join Date
    Nov 2006
    Posts
    8

    connected

    i changed the nic card and its working fine now
    my earlier nic card was realtek now its intel and its working fine now

    realtek cards are have a major problem with linux 2.6 kernel, never go for them

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •