Find the answer to your Linux question:
Results 1 to 4 of 4
i am using BLAG Linux 50002, using NetGear DG632 to access broadband DHCP creates "/etc/resolv.conf" with contents "nameserver 127.0.0.1" in it. i dont see any DNS addresses there & i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! arnuld.zero's Avatar
    Join Date
    Oct 2006
    Location
    naya nangal, Punjab, INDIA
    Posts
    14

    "DNS problem" with DHCP


    i am using BLAG Linux 50002, using NetGear DG632 to access broadband

    DHCP creates "/etc/resolv.conf" with contents "nameserver 127.0.0.1" in it. i dont see any DNS addresses there & i can not acess internet. then if i put DNS addresses there, then internet runs fast, i get full access. then problem is solved. but then on reboot DHCP deletes DNS addresses automatically. Netgear's web-interface shows that it is getting 2 DNS addresses from my ISP & they are correct.

    any idea on how can i make DHCP to add DNS addresses automatically to "/etc/resolv.conf" at every boot-up. ( there is no "dhclient.conf" file on my system but i see 2 executables in "/sbin": "dhclient" & "dhclient-script")

  2. #2
    Just Joined! arnuld.zero's Avatar
    Join Date
    Oct 2006
    Location
    naya nangal, Punjab, INDIA
    Posts
    14

    problem solved (was "DNS problem" with DHCP)

    well, i just use "Static IP addresses" now & sombody on BLAG mailing list mentioned that he also had the same problem & he just started "named" only & problem disappeared. i did the same & now internet is running without any trouble.

    but still i can not use DHCP

  3. #3
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    Go into your router and make sure its DHCP server is running.
    Alternatively, you could disable the dhcp client on your computer,
    configure a static IP address, and add the name servers to /etc/resolv.conf

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! arnuld.zero's Avatar
    Join Date
    Oct 2006
    Location
    naya nangal, Punjab, INDIA
    Posts
    14
    Quote Originally Posted by rcgreen
    Go into your router and make sure its DHCP server is running.
    Alternatively, you could disable the dhcp client on your computer,
    configure a static IP address, and add the name servers to /etc/resolv.conf
    well, i experimented with "Linux Networking" on 3 different BSDs & 3 different Linux-es for 7 days & found that on BLAG doing only *ONE* thing solves my problem:


    i just turned off IPv6 by putting these into "/etc/modprobe.conf":

    alias net-pf-10 off
    alias ipv6 off

    BTW, somebody mentioned that on BLAG mailing list didn't remember who.
    may many thanks to him & now my internet has gone supersonic, non-stop
    in both "DHCP" & "static IP" modes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •