Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18
Originally Posted by rizwanrafique So it means windows firewall knows if it's windows or Samba (???). Windows uses a special bit to detect a WIN - WIN connection and refuses ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240

    Quote Originally Posted by rizwanrafique
    So it means windows firewall knows if it's windows or Samba (???).
    Windows uses a special bit to detect a WIN - WIN connection and refuses a LINUX - WIN connection

    ... just kidding ...

    Well, that's an interesting question. Which ssh client did you use to connect from c1 to c2 with ssh?
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  2. #12
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Its Samba mount/windows share not ssh.

  3. #13
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240
    Sorry - I mixed up two different threads.
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Yea I figured.

    I don't know what is the difference between mounting a Windows share on Linux and connecting using another Windows machine connectivity wise but just a thought...may be mount works on application level and windows access other windows share on protocol level as I could already access the share from another windows machine. Don't know! Just a thought. Anyone...?

  6. #15
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240
    A FW protects ports - that's all. There is no application level checking if you use iptables.

    So it's an interesting problem. Somebody else has an idea what's wrong?
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  7. #16
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Let's not confuse one thing.
    I only had firewall running on the Windows machine. And it was only stopping connections from Linux client. Windows client connections were fine.

  8. #17
    Just Joined!
    Join Date
    Nov 2006
    Posts
    10
    Hello Everyone,
    I just used cifs to mount a windows share on linux and it works with and without firewall on windows (server machine).

  9. #18
    Just Joined!
    Join Date
    Oct 2009
    Posts
    1

    Smile w2k3 (XP) firewall can be tuned to allow Samba connections

    Quote Originally Posted by rizwanrafique View Post
    Let's not confuse one thing.
    I only had firewall running on the Windows machine. And it was only stopping connections from Linux client. Windows client connections were fine.
    I also have got problems with mount of Win shares using Samba. On many linux forums it is advised to use "-t cifs" instead of "-t smbfs", or use "mount.cifs" command instead of "mount". This doesn't work for me (Debian Lenny).
    It seems that Win XP/2003 built-in firewall restricts access to SMB share ports (TCP 139, 445) by unusual and non-documented way . Win-to-Win connection to those ports is allowed, while Samba-to-Win is disallowed.
    Remedy variants:
    1) Disable built-in firewall (this is very bad solution)
    2) Replace built-in firewall with “independent” firewall (this is a good solution, but free firewall suites are not available for Win2003 x64 Server)
    3) Modify rule for built-in Windows firewall using several mouse clicks (I’d recommend it).
    For this,
    (a) open list of firewall exceptions;
    (b) locate “File and Print Sharing” item in the list of exceptions and click on its line to select this item;
    (c) press button “Edit…”;
    (d) select row “TCP 139″;
    (e) press button “Change Scope…”;
    (f) select item “Any computer”.
    (g) Press OK;
    (h) repeat steps d-g for “TCP 445″.
    Save settings. Be happy.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •