Find the answer to your Linux question:
Results 1 to 5 of 5
Hi everyone. I'm trying to tranfer some files from my Windows machine to the Linux one. For that I have to mount the shared folder. When I run the command ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6

    linux not responding to ping


    Hi everyone.

    I'm trying to tranfer some files from my Windows machine to the Linux one. For that I have to mount the shared folder. When I run the command to mount it it times out.

    I have two interfaces, eth0 for the Internet and eth1 connected to my Windows machine (not connected to the Internet). I have checked the connection and found that I can ping my Windows machine but when I try to ping my Linux machine from the windows one it times out, funny!!!

    eth0 and eth1 are not on the same network, only to avoid linux getting confused. I've also routed the traffic to my windows machine through eth1 using the route command. the route configuration looks good to me:

    192.168.2.0 * 255.255.255.0 U 0 0 0 eth0
    10.0.0.0 * 255.0.0.0 U 0 0 0 eth1
    default 192.168.2.1 0.0.0.0 UG 0 0 0 eth0

    Both interfaces are up and Linux should know what to do with each traffic. I might have done something wrong when routing the traffic I guess. My ifconf looks good to me too:

    eth0 Encapsulamento do Link: Ethernet Endereço de HW 00:02:B3:29:A3:32
    inet end.: 192.168.2.41 Bcast:255.255.255.255 Masc:255.255.255.0
    endereço inet6: fe80::202:b3ff:fe29:a332/64 Escopo:Link
    UP BROADCASTNOTRAILERS RUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:5003 errors:4 dropped:0 overruns:0 frame:4
    TX packets:3834 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:2289684 (2.1 MiB) TX bytes:714039 (697.3 KiB)

    eth1 Encapsulamento do Link: Ethernet Endereço de HW FF:FF:FF:FF:FF:FF
    inet end.: 10.0.0.2 Bcast:10.255.255.255 Masc:255.0.0.0
    endereço inet6: fe80::fdff:ffff:feff:ffff/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:427 errors:0 dropped:0 overruns:0 frame:0
    TX packets:208 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:52128 (50.9 KiB) TX bytes:18030 (17.6 KiB)
    IRQ:11 Endereço de E/S:0xd400

    lo Encapsulamento do Link: Loopback Local
    inet end.: 127.0.0.1 Masc:255.0.0.0
    endereço inet6: ::1/128 Escopo:Máquina
    UP LOOPBACKRUNNING MTU:16436 Métrica:1
    RX packets:418 errors:0 dropped:0 overruns:0 frame:0
    TX packets:418 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:0
    RX bytes:29621 (28.9 KiB) TX bytes:29621 (28.9 KiB)

    Ah! Both firewalls are disabled, double-checked.

    It's driving me crazy, I would appreciate any help. thanx a lot!!!

    Llanos

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    Both firewalls are disabled, double-checked.
    How did you disable iptables? What does iptables -nvL show you?

    Also, what does cat /proc/sys/net/ipv4/icmp_echo_ignore_all show you?

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    33

    Smile disable firewall

    disable firewall in windows pc &

    execute this command in linux box

    HTML Code:
    #iptables -F
    this command will disable firewall in ur linux machine

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6
    Hi there

    thanx a lot for your suggestions.

    I've been able to ping ,finally... I can ping my win machine from my linux one and viceversa. I did the iptables -F to disable the firewall and after restarting i was able to ping. I had disabled it through the GUI, that maybe was the problem.

    After being able to ping I tried to mount my shared folder on my Win machine with smbmount //IPaddress/folder but it always times out. I've also tried with smbclient but it also times out. When I do smbclient -L //IPaddress is the same, TIMES OUT!!!

    Anomie, answering your questions:
    cat /proc/sys/net/ipv4/icmp_echo_ignore_all prints 0.
    iptables -nvL shows:
    CHAIN INPUT (policy ACCEPT 9170 packets, 7777K bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 9371 packets, 1325 bytes)
    pkts bytes target prot opt in out source destination

    I guess that when Linux tries to access the Win one Win takes time to respond and it times out. Is there anyway to make the Linux one wait a bit longer. I'm relatively new to Linux and I do appreciate your help.

    Cheers!!!

    Llanos

  5. #5
    Just Joined!
    Join Date
    Dec 2011
    Posts
    1
    Quote Originally Posted by Llanosflats View Post
    eth1 Encapsulamento do Link: Ethernet Endereço de HW FF:FF:FF:FF:FF:FF
    inet end.: 10.0.0.2 Bcast:10.255.255.255 Masc:255.0.0.0
    endereço inet6: fe80::fdff:ffff:feff:ffff/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    Why is the MAC address of your eth1 FF:FF:FF:FF:FF:FF ?
    This is a boradcase MAC.
    Maybe your card lost its MAC, maybe you have an option to reprogram the MAC?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •