Find the answer to your Linux question:
Results 1 to 7 of 7
This is getting crazy, all I want is to connect to the internet through my Linux Fedora and I'm stumped.... if anyone can point me in the right direction (me=a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    5

    Cable Modem through USB - Why so hard?


    This is getting crazy, all I want is to connect to the internet through my Linux Fedora and I'm stumped.... if anyone can point me in the right direction (me=a total Linux newbie) to configure my cable modem i'd be the happiest newb on the planet.

    I have been at this for 3 days now... lol

    Here is my set-up

    Motorola Surfboard SB5100 Cable Modem
    Connected through USB as I dont have NIC card
    Fedora core 1


    I have Fedora newly installed on a Dual Boot with windows XP - (in which the modem works fine with the ISP modem install disk.)

    Motorola dont seem to make a driver/install package for linux. So I am stuck trying to set this up manually which I dont mind its half the fun of linux for me, but I just can't find the information to do this in a way my little ole' brain can't understand at my zero linux knowledge level.

    From what I've read some information which might be useful from the dmesg command (the only one I know how to get to work
    Code:
    CDCEther.c: Found CDC version 110
    CDCEther.c: imperfect filtering support - need sw hashing
    CDCEther.c: Cant use SetEthernetMulticastfilters request
    CDCEther.c: Detected BULK OUT packets of size 64
    also maybe useful in identifying problem is:
    Code:
    CDCEther.c: eth0 Broadcom Corporation USB Cable Modem (My MAC)
    CDCEther.c: eth0 (My MAC here again)
    So it seems to identify my MAC address and some sort of make for my modem which doens't seem right since its a motorola.

    Any suggestions as to how to sonfigure this thing would be much appreciated.

  2. #2
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    Hmmm...I have had my share of cablemodem problems and yours sounds a little weird. I didn't even know you could attach a cable modem via USB without a NIC card and have it work; makes me wonder if there isn't an onboard NIC you are using without realizing it, but then it wouldn't work through USB. Heh. Maybe there is a USB NIC you are hooked up to without realizing it? Sorry if it sounds silly.

    What I did was to go out and buy a NIC for my PC. A good one from 3COM or equivalent may cost you a whopping 10 to 15 bucks, and I sure as heck felt it was worthwhile after I finally got sick of trying to make the USB one the company gave me work, then the onboard one work, and alternating from windows to linux and back.

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    5
    Hi
    I run suse 9.0 personel and i tried for 4 days to get online

    I run a motorola SB4200 via a network card with an ethernet cable(From modem to network card which was pre installed on my mobo)because of the trouble linux has with usb`s

    I Phoned my isp (Telewest)and i had to register my network card (Some isp`s just ask for name &password)then hey presto it all works

    I set up a network but with no slaves !

    I to am a linux "virgin" but learning all the time

  4. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    5
    Thanks for the replies.

    I am also with Telewest in the UK, and have my modem already registered with telewest as I use it with windowsXP (dual boot) no problem.

    I think I may have to pay out for a NIC card, as the posts I have read in diffrent places seem to suggest that using a NIC in Linux seems to be simple to set up, and certain network USB devices cause confusion to Linux.

    One more question, would it be possible to use that 'Wine' program to access my Firefox browser installed in windows, and therefore allow the modem (which works fine in XP) to run off of the working windows drivers??

    or does the device need to be set up in Linux AND windows to work???


    Thanks for any help you can give.

  5. #5
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    678

    Working

    Just finished setting up a surfboard sb1500 connecting to Telewest's cable service in the UK. Here is what you need, assuming USB is working with other devices:

    CDCEther module is used to drive the modem itself, and usbnet to establish a connection to it

    modprobe CDCEther
    modproce usbnet

    Next you need to register the MAC address of the usbnet device with blueyonder to allow access. To find this out connect to modem through the USB cable (otherwise the usbnet device will not work) and type the following:

    ifconfig -a

    The device you are interested in is the newest ethX device. After a delay for the new address to be activated, the device should configure itself with DHCP.

    The modules will need to be put into /etc/modules.conf to to allow for reboots, but after that everything should work.

    Hope this helps

  6. #6
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    678

    Follow up

    Having spoken to a few other folk about this, there are a couple of other issuse that need to be dealt with in some cases.

    First of all, it seems that Mandrake's setup wizard doesn't recognise USBNET devices so you will have to configure it by hand. The files you are interested in are:

    /etc/resolv.conf
    /etc/sysconfig/network
    /etc/sysconfig/network-scripts/ifcfg-(network device)

    Secondly, if you put CDCEther and usbnet in your /etc/modules file, they will register the usbnet device before any existing network cards, this will mean it appears as eth0 when all the time you were setting it up it was eth1.

    I think there are ways to specify which device is assigned to which driver, but I'm not sure what they are. Anyone else know how, or am I making it up?

    Chris...

  7. #7
    Just Joined!
    Join Date
    May 2004
    Posts
    1

    Scientific Atlanta USB Cable Modem Telewest CDCEther

    Persevere for it CAN be done - for I have (probably by accident)

    MDK 9.0 allows you to select the CDCEther driver and it connects to the internet no problem. I am also with Telewest - registered the MAC address of a PCMCIA NIC previously. Its important to have one but I don't think it checks it. MDK9.0 complains during shutdown that the MAC address doesn't match eth0. It still worked.

    However, recent upgrade to MDK10.0 failed (as well as pinching my SVG desktop)! RH9 and Fedora Core were okay (using dhcpcd).

    I am currently in Gentoo stage 1 hell - the LiveCD detects and can net-setup eth0 okay but my new kernel 2.6 doesn't .

    lsmod

    If you don't see CDCEther then modprobe CDCEther. If it can't find the module... er

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •