Find the answer to your Linux question:
Results 1 to 4 of 4
Hey all! im having trouble establishing a domain connection to the net, here's the deal: - I'm running Redhat Fedora Core Release 1 - i can ping computers on the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Location
    columbus, oh
    Posts
    2

    Internet Connectivity DSN Issue


    Hey all! im having trouble establishing a domain connection to the net, here's the deal:

    - I'm running Redhat Fedora Core Release 1
    - i can ping computers on the local network, and ping websites at their ip addresses, not domain names

    whenever i try to connect to anything non-ip in mozilla, even 'localhost', i get: '... could not be found. please check the name and try again.'

    these symptoms lead me to believe there is a dns problem.

    my /etc/resolv.conf file is set to the following DNS ip addresses, which my ISP provided me:
    nameserver 207.69.188.185
    nameserver 207.69.188.186

    My network is set to get all settings, including DNS via DHCP from my router, 192.168.0.1.

    I would appreciate help! thanks

    - Ross

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Do those DNS servers work for other computers? Is there anything else in your resolv.conf? If you can, try some different DNS servers...and post the whole resolv.conf if that's not it...
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    stuff

    I would set the dns server address on the router to point to the ones given to you by your isp.

    Then enable the caching / forwarding dns server on the router.
    set the dns server address on your pc to the routers ip. or get auto DHCP
    set the gateway address on your pc to the routers ip. or get auto DHCP

    That should work.

    The problem is likely to be that the name resolution packets are not being routed - for some reason. Is the gateway address on your pc set to the router's ip?
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    You have said that you set the DNS servers in /etc/resolv.conf but you also say that you are getting your DNS from DHCP I guess that this could be causing the problems. Do you also filter outgoing packets?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •