Find the answer to your Linux question:
Results 1 to 6 of 6
After groping about for a long time, i have now realised that the best thing suited for what i am trying to do is "ssh" I still have a problem. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    59

    using ssh


    After groping about for a long time, i have now realised that the best thing suited for what i am trying to do is "ssh"
    I still have a problem. I have downloaded the tar-ball and correctly installed it on both my machines. I am still not able to log into my cluster machine through my slave.

    Here are the details:
    server machine :
    IP : 192.168.1.100
    Hostname : linux
    Domain : site

    Client machine:
    IP : 192.168.1.10
    Hostname : machine1

    And what exactly should i type at the client machine to log into the server machine.?
    This is what I have tried so far :
    # ssh root@linux.site
    didnt work
    # ssh root@192.168.1.100
    didnt work
    and some other combinations. still no positive result.

  2. #2
    Just Joined! lizardking's Avatar
    Join Date
    Aug 2006
    Location
    St-Lazare, Quebec
    Posts
    28
    Howdy kris.c!

    Silly question, does your host.allow file on 'linux' have machine1?

  3. #3
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,929
    Normally root logins over ssh are turned off by default, and this is the way you should try and keep it. When you log in over ssh, log in as a regular user and use 'su' or 'sudo' to do sysadmin stuff.

    Make sure you have a regular user account on the machine '192.168.1.100' and do 'ssh <username>@192.168.1.100'. That should work a lot better.
    Linux user #126863 - see http://linuxcounter.net/

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    59
    Well, sorry about that , I am still pretty much new. But, I checked it up, it first scans "hosts.allow" and then "hosts.deny". If a match is not found in either file, the access is still allowed. So, my mistake is not there I suppose.

    yeah, I did that too : # ssh <username>@192.168.1.100
    it blinked for a long time before saying that the destination was unreachable.

    I can "ping" one machine from another, so, connectivity is not a problem.

    And the ssh daemon is running on both the machines too,
    Code:
    # ps -aux | grep sshd
    root      4379  0.0  0.7   4700  1972 ?        Ss   22:26   0:00 /usr/sbin/sshd -o PidFile=/var/run/sshd.init.pid
    1000      5668  0.0  0.2   2728   672 pts/1    R+   22:55   0:00 grep sshd
    And,
    >Make sure you have a regular user account on the machine '192.168.1.100'
    The account I use to login should suffice right?


    Prior to this , I had downloaded with ssh-3.0.1
    I did the following as root on both the machines:

    # ./configure
    # make
    # make install

    I am sure nothing went wrong there too.
    Please help....

  6. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    59
    well, I just found this :
    http://www.linuxforums.org/forum/lin...ing-works.html

    and the problem was indeed with the firewall itself. I still have an issue with authentication, but atleast , i am not getting "destination unreachable" anymore.
    Thanks.

  7. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    59

    authentication problem

    Can you help me out:

    Code:
    # ssh <username>@192.168.1.100
    Host key not found from database
    Key fingerprint:
    xipoc-kofur-ratag-gavup-sigec-cemub-kekof-gafan-tacut-reduv-roxox
    You can get a public key's fingerprint by running 
    % ssh-keygen -F publickey.pub
    on the key file.
    Are you sure you want to continue connecting (yes/no)? yes
    Host key saved to /root/.ssh/hostkeys/key_22_192.168.1.100.pub
    host key for 192.168.1.100, accepted by root Wed Dec 20 2006 23:07:58 +0530
    warning: Authentication failed.
    Disconnected; no more authentication methods available.
    So, next i tried

    Code:
    # ssh-keygen -F key_22_192.168.1.100.pub
    Fingerprint for the key:
    xipoc-kofur-ratag-gavup-sigec-cemub-kekof-gafan-tacut-reduv-roxox
    and for all the subsequest attempts :

    Code:
    # ssh <username>@192.168.1.100
    warning : Authentication failed
    Disconnected; no more authentication methods available.
    what do i do to correctly login?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •