Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I have Smart Link 56K Voice Modem inserted into PCI slot of my Intel D865GBF motherboard. I have Fedora Core 6 on PATA hdd & WinXp on SATA hdd. WinXP ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    16

    modem detection


    I have Smart Link 56K Voice Modem inserted into PCI slot of my Intel D865GBF motherboard.

    I have Fedora Core 6 on PATA hdd & WinXp on SATA hdd.

    WinXP had perfectly installed my modem. I didn't need any driver CD.
    How can I install my modem in FC 6 ???
    How can I know which devices are installed in my system from FC 6 which is quite simple in WinXP through Device Manager!!!

  2. #2
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi rachin,

    How can I know which devices are installed in my system from FC 6 which is quite simple in WinXP through Device Manager!!!
    You can list all the connected PCI devices by running lspci command as follows : -

    $ /sbin/lspci
    How can I install my modem in FC 6 ???
    You can download the driver for the modem at the following link : -

    http://linmodems.technion.ac.il/pack...0061021.tar.gz

    Extract the archive and read the README file in it to know how to install the driver and configure the modem.

    With Regards,
    Thinker

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    16

    Modem installation Error

    Hi,
    I did what you told me to. I downloaded the driver, extracted it in my
    /home/rachin, cd into the slmodem-2.9.11-20061021 folder and then after reading the Readme file, I followed the instructions. While executing make command, it showed many messages with some errors too. Any way I completed all the commands and finally when I executed the modprobe slamr command it showed me a message:
    FATAL:Module slamr not found

    There is the mention of
    KERNEL_DIR=/path/to/linux
    Default KERNEL_DIR is '/lib/modules/<kernel-version>/build.
    Many linux distributions use directory '/usr/src/linux-<version>' also.

    I didn't change anything becoz I didn't understand it.

    By the way, lspci command is giving this line:

    01:00.0 Modem: Smart Link Ltd. Unknown device 2800 (rev 02)

    Can you give me exact instructions ??? It'll be very helpful for me. Thanks.

  4. #4
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi rachin,
    Please repeat the procedure mentioned in the README file as root and post the error messages that you saw on each step so that the problem could be understood.

    With Regards,
    Thinker

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    16

    Error during modem installation

    I am using this convention for the sake of my fingers

    modemdirpath = /home/rachin/slmodem-2.9.11-20061021
    --------------------------------------------------------

    [root@localhost slmodem-2.9.11-20061021]#make
    Output:

    make -C modem all
    make[1]: Entering directory 'modemdirpath/modem'
    make[1]: Leaving directory 'modemdirpath/modem'
    make -C drivers KERNEL_DIR=/lib/modules/2.6.18-1.2798.fc6/build
    make[1]: Entering directory 'modemdirpath/drivers'
    cc -I/lib/modules/2.6.18-1.2798.fc6/build/include -o kernel-ver kernel-ver.c
    make all KERNEL_VER=2.6.18-1.2798.fc6
    make[2]: Entering directory 'modemdirpath/drivers'
    make modules -C /lib/modules/2.6.18-1.2798.fc6/build SUBDIRS=modemdirpath/drivers
    make[3]: Entering directory '/usr/src/kernels/2.6.18-1.2798.fc6.1586'
    CC [M] modemdirpath/drivers/amrmo_init.o
    modemdirpath/drivers/amrmo_init.c: 46:26: error: linux/config.h: No such file or directory
    make[4]: *** [modemdirpath/drivers/amrmo_init.o] Error 1
    make[3]: *** [_module_/modemdirpath/drivers] Error2
    make[3]: Leaving directory '/usr/src/kernels/2.6.18-1.2798.fc6-1586'
    make[2]: *** [all] Error 2
    make[2]: Leaving directory 'modemdirpath/drivers'
    make[1]: *** [all] Error 2
    make[1]: Leaving directory 'modemdirpath/drivers'
    make: *** [drivers] Error 2

    [root@localhost slmodem-2.9.11-20061021]#make install
    Output:

    It gave same output as above.

    Is this sufficient?

  6. #6
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi rachin,

    make[3]: Entering directory '/usr/src/kernels/2.6.18-1.2798.fc6.1586'
    CC [M] modemdirpath/drivers/amrmo_init.o
    modemdirpath/drivers/amrmo_init.c: 46:26: error: linux/config.h: No such file or directory
    config.h file is deprecated in the new Fedora Core 6 kernel 2.6.18-1.2798.fc6 source tree. So, what you can do is either create a blank config.h file in /usr/src/kernels/2.6.18-1.2798.fc6.1586/include/linux directory or comment all the references to config.h or change all the references from config.h to autoconf.h.

    So, try creating a blank file config.h in the directory /usr/src/kernels/2.6.18-1.2798.fc6.1586/include/linux by running the following command in that directory : -

    # touch config.h
    You can create one in /usr/include/linux too. As sometimes this may also be required for some compilation. Try installing the modem again after doing this.

    With Regards,
    Thinker

  7. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    16

    installing modem

    After make and make install command, I do this:

    [root@localhost ~]# modprobe slamr
    [root@localhost ~]# /usr/sbin/slmodemd --country=USA /dev/slamr0
    SmartLink Soft Modem: version 2.9.11 Jan 2 2007 21:02:38
    symbolic link `/dev/ttySL0' -> `/dev/pts/4' created.
    modem `slamr0' created. TTY is `/dev/pts/4'
    Use `/dev/ttySL0' as modem device, Ctrl+C for termination.


    From the Output of the 'dmesg' command:
    ---------------------------------------
    slamr: module license 'Smart Link Ltd.' taints kernel.
    slamr: SmartLink AMRMO modem.
    slamr: probe 2000:2800 SL2800 card...
    PCI: Enabling device 0000:01:00.0 (0110 -> 0112)
    ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 21 (level, low) -> IRQ 169
    slamr: slamr0 is SL2800 card.

    From the Output of the 'lspci' command:
    ---------------------------------------
    01:00.0 Modem: Smart Link Ltd. Unknown device 2800 (rev 02)

    From the Output of the 'wvdial /etc/wvdial.conf' command:
    ---------------------------------------------------------
    --> WvDial: Internet dialer version 1.54.0
    --> Warning: section [Dialer /etc/wvdial.conf] does not exist in wvdial.conf.
    --> Cannot open /dev/modem: No such file or directory
    --> Cannot open /dev/modem: No such file or directory
    --> Cannot open /dev/modem: No such file or directory

    I opened /etc/wvdial.conf file. It was empty. Is my modem installed now?
    If yes how can I configure it permanently to use internet?

  8. #8
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi rachin,
    Before running wvdial, run wvdialconf so as to generate the dialer configuration file containing modem and ISP information. While running wvdialconf, it will scan for installed modem and automatically finds the pseudo-terminal with the symbolic link which in your case should be /dev/ttySL0. After that, post the contents of the file /etc/wvdial.conf.

    Remove the ';' in front of Phone, Username and Password lines and fill in the respective information at each line. Remember to add the line, 'Carrier Check = no' to your generated wvdial.conf file. Save the changes.

    Once this has been done, now, run wvdial to connect to the Internet and if the information you have entered is correct, you will get connected. To disconnect, terminate wvdial using CTRL+C.

    With Regards,
    Thinker

  9. #9
    Just Joined!
    Join Date
    Dec 2006
    Posts
    16

    Browsing Failed!

    I performed these steps:

    In one terminal
    --------------
    [root@localhost slmodem-2.9.11-20061021]# /usr/sbin/slmodemd --country=USA /dev/slamr0
    SmartLink Soft Modem: version 2.9.11 Jan 2 2007 21:02:38
    symbolic link `/dev/ttySL0' -> `/dev/pts/3' created.
    modem `slamr0' created. TTY is `/dev/pts/3'
    Use `/dev/ttySL0' as modem device, Ctrl+C for termination.

    In another terminal
    ------------------
    [root@localhost ~]#wvdialconf /etc/wvdial.conf

    Content of wvdial.conf after above command
    -------------------------------------------
    [Dialer Defaults]
    Modem = /dev/ttySL0
    Baud = 460800
    Init1 = ATZ
    Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ISDN = 0
    Modem Type = Analog Modem
    ; Phone = <Target Phone Number>
    ; Username = <Your Login Name>
    ; Password = <Your Password>

    [root@localhost ~]# wvdial
    --> WvDial: Internet dialer version 1.54.0
    --> Cannot get information for serial port.
    --> Initializing modem.
    --> Sending: ATZ
    ATZ
    OK
    --> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    OK
    --> Modem initialized.
    --> Sending: ATDT15100
    --> Waiting for carrier.
    ATDT15100
    CONNECT 54667
    --> Carrier detected. Waiting for prompt.
    Welcome to World Link Birgunj:
    Username:
    Username:
    --> Looks like a login prompt.
    --> Sending: june15
    june15
    Password:
    --> Looks like a password prompt.
    --> Sending: (password)
    ********
    ~[7f]}#@!}!}!} }8}!}$}%\}"}&} } } } }%}& u}(.}'}"}(}"[0f]5~
    --> PPP negotiation detected.
    --> Starting pppd at Sun Jan 7 13:33:59 2007
    --> pid of pppd: 3831
    --> Using interface ppp0
    --> pppd: Modem
    --> pppd: Modem
    --> local IP address 202.79.56.12
    --> pppd: Modem
    --> remote IP address 202.79.56.34
    --> pppd: Modem
    --> primary DNS address 202.79.56.39
    --> pppd: Modem
    --> secondary DNS address 202.79.32.40
    --> pppd: Modem

    I get quite excited when I saw above display, but soon after when I tried to browse using Mozilla Firefox it didn't display the page. I feel like dig a hole & buried into it

    I think modem is installed & detected then why not browsing???

    & one thing more plzzz, do I have to '/usr/sbin/slmodemd --country=USA /dev/slamr0' & 'wvdial' everytime? Cann't I create a shortcut on the desktop for executing both commands at once?

  10. #10
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi rachin,
    Did you add the line "Carrier Check = no" to your generated wvdial.conf file? Check the Firefox connection settings, whether it is set to Direct Connction to Internet or not. Also, check if IPv6 is disabled in Firefox.

    Quote Originally Posted by rachin
    do I have to '/usr/sbin/slmodemd --country=USA /dev/slamr0' & 'wvdial' everytime?
    It is better to have the SmartLink Modem Daemon running at the time of booting, so that you only need to run wvdial to connect to Internet. For that, add the following line to /etc/rc.d/rc.local file : -

    /usr/sbin/slmodemd --country=USA /dev/slamr0 &
    Also, add your login information to /etc/wvdial.conf file so that you do not have to type it everytime you try to connect to Internet.

    With Regards,
    Thinker

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •