Find the answer to your Linux question:
Results 1 to 4 of 4
my PC has an integrated SiS 190/191 Fast Ethernet Adapter. I had installed Red Hat Linux AS 4 but it was unable to detect my lan card. i searched the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Location
    Hyderabad, India.
    Posts
    4

    Interrupt:11 Base address: 0xdead


    my PC has an integrated SiS 190/191 Fast Ethernet Adapter. I had installed Red Hat Linux AS 4 but it was unable to detect my lan card.
    i searched the SiS website for the drivers and found one. I followed the steps given in the read me file

    In the "Readme" text :


    1. Install Fedora Core 3. (Currently only FC3 can be installed on 965 demo board.)

    2. Download Linux kernel 2.6.9 or latter version from http://www.kernel.org. The follwing examples are based on linux-2.6.9.

    3. copy the kernel source to the location /usr/src/linux-2.6.9.

    4. cp sis190.c /usr/src/linux-2.6.9/drivers/net

    5. Edit the file "/usr/src/linux-2.6.9/drivers/net/Kconfig".
    a. Serach for the string "config SIS900"
    b. Add the following item below the item of SIS190.

    config SIS190
    tristate "SiS 191/190 PCI Gigabit/Fast Ethernet Adapter support"
    depends on NET_PCI && PCI
    select CRC32
    ---help---
    Say Y here if you have a SiS 191/190 PCI Gigabit/Fast Ethernet adapter.

    To compile this driver as a module, choose M here: the module
    will be called sis190. This is recommended.

    6. Edit the file "/usr/src/linux-2.6.9/drivers/net/Makefile".
    a. Search for the string "obj-$(CONFIG_SIS900) += sis900.o".
    b. Insert "obj-$(CONFIG_SIS190) += sis190.o" to next line.

    7. cd /usr/src/linux-2.6.9

    8. Input the command 'make menuconfig'. Then the Linux Kernel configuration menu will be popped.
    a. Select "Device Drivers -->", "Networking support -->", "Ethernet (10 or 100Mbit) -->".
    b. Goto the item "SiS191/190 PCI Gigabit/Fast Ethernet Adapter support".
    c. Press space key to make this item marked with <M>.
    d. Save and exit the kernel configuration menu.

    9. Make kernel and modules. Input the command 'make bzImage modules modules_install install'.

    10. Reboot and Select the boot item "2.6.9".


    //** Probe sis190 module **//

    1. Input the command 'rmmod sis190'.

    2. Input the command 'modprobe sis190'.

    3. Input the command 'ifconfig eth0 <ip_addr>'.
    a. <ip_addr> is the IP address of sis190.
    b. example: 'ifconfig eth0 192.168.209.1'.

    [ i followed the above steps using the latest kernel (2.6.19.1)]
    [in the step 8-a, i could not find the driver in Ethernet 10 or 100 Mbit) but i found it in Ethernet 1000 Mbits !!! ]

    after the reboot, kudzu detected my card and configured it.
    now, i can ping my own ip address, but can't ping my gateway.
    this is the result of ifconfig ...

    eth0 Link encap : Ethernet Hwaddr 00:11: D8:4F:58:EF
    inet addr : 192.168.11.194 Bcast : 192.168.11.255 Mask : 255.255.255.0
    inet6 addr : fc80::211:d8ff:88ee/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets : 3429 errors:0 dropped:0 overrun:0 frame:0
    TX packets : 24 errors:0 dropped:0 overrun:0 carrier:0 collision:0 txquelen:1000
    RX bytes :427539 (471.8 Kib) TX bytes: 1440 (1.4 Kib)
    Interrupt:11 Base address: 0xdead


    i guess the last line "Interrupt:11 Base address: 0xdead" is the problem here.
    i have no clue what to do ??? please help me.

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,933
    Despite the address reading 0xdead, I dont think this is the problem - the interface looks like its working just fine. The problem is likely to be elsewhere.

    - Maybe your gateway is not responding to ICMP Ping requests (it is common to turn this off to hide your internet presence from would-be hackers).
    - Maybe your machine has a firewall, and it is getting back a ping response which is being blocked by your local firewall for some reason.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Location
    Vienna, Austria
    Posts
    10

    0xdead (sis190)

    hi

    right now I have the same problem with the sis-onboard-gigabit-lan and a google brought me here ...

    it is not the firewall (gateway) nor iptables set on the local machine ...

    I have a 100Mbit D-link - so maybe this is the reason - maybe this onboard card cannot "downgrade" from 1000Mbit to 100Mbit?? but how to trace this?

    any hints, what I could do? Are there some options i need to set with modprobe sis190?

    by the way - patch-cable is okay (checked it twice)!
    kernel is
    2.6.20.5 on a slackware-11.0

    thx for ur help!!
    Michael

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! filippos's Avatar
    Join Date
    Jul 2005
    Location
    Athena, Ellas
    Posts
    21
    I have the same problem. The driver is to blaim.
    Have you solved it? Please help.
    SuSE 10.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •