Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Originally Posted by gul_funky if the problems is my network configuration,can u guide me on how to check my network so that i can make sure that my window and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,865

    Quote Originally Posted by gul_funky
    if the problems is my network configuration,can u guide me on how to check my network so that i can make sure that my window and linux are in the same workgroup...
    Right - firstly you should be trying to browse the server using '\\<netbios_name>' which, for your samba server will be its unix hostname.

    Secondly, the value for 'workgroup=...' in you [global] section of smb.conf should be exactly the same as the workgroup or domain name that the windows machines use (right click the 'my computer' icon on the desktop, select 'properties', click the 'Computer Name' tab. At the bottom of the tab it says 'To rename this computer or join a domain, click 'Change' followed by a button marked 'Change...' - press this button. You set the domain/workgroup name here and the computer (netbios) name. You can use either a domain name or a workgroup name, but you'll need a domain controller to use a domain, if you dont have one of those then select workgroup. It is very important to make sure the domain or workgroup name matches exactly that specified in the smb.conf file on the Linux server.)

    Restart samba then restart your windows computers.

    If you have more than one windows machine, test the netbios names by having each browse the other; open the Start->run box and type \\<netbios_name> of another windows computer to make sure it's all working.

    Then try '\\<server_name>' in the run box - you should be able to see the server. If it's working, flip back to 'security=user', and set up user accounts with 'smbpasswd -a ...' for each user, adding Unix/Linux user accounts with 'useradd' first if they dont already have these accounts. Make sure their windows user name and their Linux user name match exactly. Set their samba password to be identical to the one they log onto windows with.
    Linux user #126863 - see http://linuxcounter.net/

  2. #12
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6
    thanks guys...
    i just discovered what my problem is...
    it is only the firewall matter...
    i need to disable SELINUX protectionfor smbd daemon...
    thanks for your help guys...

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •