Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
i just set up my fedora core 5 with samba server then i try to run the shared file on window xp.and i got this problem;the folder is exist but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6

    Samba-Problem on accessing shared file


    i just set up my fedora core 5 with samba server then i try to run the shared file on window xp.and i got this problem;the folder is exist but user cannot access it.Eventhough i've set to 'allow all user access' but it still doesnt work. the error return was

    \\<ip address>\<file directory> is not accesible. The Network cannot be found.
    anyone know what actually the problem is??plz help me...

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    15
    have you tried to ping the ip server of your samba server from the client machine and from your machine to the client? if there's no connection maybe you have mistakenly configured your Netwrok Configuration

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6
    i've tried before ping the ip address from both machine...
    and the network is fine...
    the only problem is access denied...
    i'm a newbie to linux and samba server and i dont have any experience using it...
    so i dont have any idea on how to solve this problem...

  4. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    15
    so theres a connection. maybe you have misconfigured your smb.conf file. have you modified it? be sure to configure your share folders, security settings and your workgroup

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6
    this is my shared file

    [TRAINEE]
    path = /home/Nadhira/TRAINEE
    writeable = yes
    browseable = yes
    share modes = yes
    guest ok = yes


    i dont know wats the problem since i'm new to this server...
    i'm doing this project for my practical training actually...
    any other parts that i should configure or edit....??

  6. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846
    You could try looking at '\\<netbios_name>' from windows, then browse to the share you need?
    Linux user #126863 - see http://linuxcounter.net/

  7. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6
    i've tried but still cannot access...
    the error returned was

    //<ip_address> cannot be accessed.You might not have permission to access

    The Network path cannot be found.

  8. #8
    Just Joined!
    Join Date
    Dec 2006
    Posts
    15
    try to access your own smb server. open file browser>smb://<your ip>. if theres an error please check your smb.conf. did you edit the host allow directive be sure to allow your network there.

    PS: im also new to smb server.

  9. #9
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846
    On the server, in the config file, under the [general] section, what does it say for the line that begins 'workgroup='? You should set this to be the same as the workgroup or domain name used by the windows machines.

    And what does it say on the line that starts 'security='? You could try changing 'security = user' to 'security = share' for a moment to see if samba is working on the lan.

    Dont forget to restart samba after each change to smb.conf with...
    Code:
    service smbd restart
    as root.

    If you're still having difficulties, then you may want to post-up the [general] section out of your smb.conf file.
    Linux user #126863 - see http://linuxcounter.net/

  10. #10
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6
    ok..i've tried all those thing but still wont work..
    it keep saying this
    \\<ip adress> is not accesible.You might not haver permission to access this file.

    The network path cannot be found.
    i post my smb.conf code so that its easy for you to understand...

    [global]
    workgroup = putralrt
    server string = Samba Server
    printcap name = /etc/printcap
    load printers = yes
    cups options = raw
    log file = /var/log/samba/%m.log
    max log size = 50

    dns proxy = no
    security = share

    [homes]
    comment = Home Directories
    browseable = no
    writeable = yes

    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no

    [TRAINEE] <---- my shared file
    path = /home/Nadhira/TRAINEE
    writeable = yes
    browseable = yes
    share modes = yes
    guest ok = yes
    i even tried add this code
    hosts allow = 192.168.10.2 / 255.255.255.0
    security = share
    but cant work...
    anything that i've missed here??

    p/s : i'm using samba Version 3.0.21b-2

    if the problems is my network configuration,can u guide me on how to check my network so that i can make sure that my window and linux are in the same workgroup...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •