Find the answer to your Linux question:
Results 1 to 2 of 2
Greetings, all. I recently upgraded a RedHat 7.3 machine to Fedora Core 6. The only networking available to the machine is the on-board 10/100 Davicom Ethernet controller, which is connected ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Location
    Austin, TX
    Posts
    2

    IPv4 default route disappears


    Greetings, all.

    I recently upgraded a RedHat 7.3 machine to Fedora Core 6. The only networking available to the machine is the on-board 10/100 Davicom Ethernet controller, which is connected to a 10/100 Mbps Ethernet switch / firewall router. The Ethernet port is configured with a static IP address, the IP address of the firewall router as its default gateway, etc., etc.

    After booting up the system, the Ethernet port can see other systems for about 10 seconds. After that, the default route starts to flake out. For example, if I do a "netstat -r", I see that access to my 192.168.123.0 LAN is available through eth0, but then the output hangs for 30 seconds before printing the default route. If I try to ping ANY other machine on my LAN, I get a "Destination Host Unreachable".

    At first, I thought this might be related to the NetworkManager, but I've disabled it (and even uninstalled the RPMs), but that had no effect.

    If I unplug my Ethernet cable and plug it back in, I can see in /var/log/messages that the link goes down and up, and then I can ping other machines for about 10 seconds. And then, again, the default route entry flakes out.

    Help?

    Could this be related to Ethernet full-duplex/half-duplex auto-sensing? If so, how can I hard-set the hardware to do one or the other?

    --whitting

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Location
    Austin, TX
    Posts
    2

    Problem solved...

    Ok, I solved the problem, although I'm not sure what really solved it. Here's what I did:

    1. I installed the Fedora Unity 070111 release (previously it was FC6)

    2. While specifying the networking parameters for my Ethernet card, I specified the netmask as "24" rather than "255.255.255.0".

    It sounds weird, but I think that specifying the IP address as "192.168.1.2/24" made the difference. Still, under the FC6 install, I did check /etc/sysconfig/network and /etc/sysconfig/network-scripts/ifcfg-eth0, and they looked Ok.

    Anyway, problem solved. Sorry about the waste of bandwidth and/or disk space.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •