Find the answer to your Linux question:
Results 1 to 6 of 6
guys i've been suffering from this freaking "Permission Denied" error from days, and no solution seems to work. I extensively searched the net and have gone through almost all the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    6

    Question nfs Permission Denied


    guys i've been suffering from this freaking "Permission Denied" error from days, and no solution seems to work. I extensively searched the net and have gone through almost all the forum reps i could find but

    here are my configs

    My nfs server is Roh-06[172.16.7.26]
    it shares two volumes, below is my /etc/exports
    /home/lamcluster/common 172.16.0.0/255.255.0.0(rw,sync,no_root_squash)
    /root/demos 172.16.0.0/255.255.0.0(rw)
    and below is my hosts.allow file
    portmap: 172.16.0.0/255.255.0.0
    lockd: 172.16.0.0/255.255.0.0
    rquotad: 172.16.0.0/255.255.0.0
    mountd: 172.16.0.0/255.255.0.0
    statd: 172.16.0.0/255.255.0.0
    hosts.deny is ALL:ALL

    now when i try to mount /home/lamcluster/common from any root/non-root user I get a "permission denied" error

    however [and strangely] if i mount /root/demos from any root/non-root user, it works fine

    I don't if it matters but i even tried keeping the same usernane/userids on client and server machines and also note that firewall is turned off

    I wish anybody can help me in this regard, plzzzzzzzzzzzz

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    52
    I know this is really basic but it still catches me occasionally...
    Have you ensured that your UID numbers match between systems? (i.e. jkennedy has a UID of 1000 on both servers.)

  3. #3
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,879
    And does the server have any local port-blocking firewall turned on?
    Linux user #126863 - see http://linuxcounter.net/

  4. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    6
    @ennoil
    as i told earlier, userid is same on both [501]

    @RoxOff
    and the firewall is turned off on both PCs

  5. #5
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,879
    If you temporarily remove the ALL:ALL from /etc/hosts.deny does it work then? Or if you put 'ALL:172.16.0.0/16' in /etc/hosts.allow?
    Linux user #126863 - see http://linuxcounter.net/

  6. #6
    Just Joined!
    Join Date
    Jan 2007
    Posts
    6
    i'll try this though i'm not pretty confident about it. The thing bothering me is that i'm able to mount the /root/demos folder from any root/non-root user on client [which has same options as u can see in my 1st post]. So i guess its some permission problem with /home/lamcluster/common [lamcluster is username and i've tried setting the permission for the folder to 777 but it didn't work]

    however i'll try ur suggestion

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •