Find the answer to your Linux question:
Results 1 to 10 of 10
Is this setup possible? ISP Modem ---> local router (Linksys) ---> linux webserver Or does it necessarily have to be? ISP Modem ---> linux webserver ---> local router (Linksys) Thanks...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! soccercisco's Avatar
    Join Date
    Dec 2006
    Location
    So. Cal
    Posts
    98

    [Solved] Simple Question Networking


    Is this setup possible?

    ISP Modem ---> local router (Linksys) ---> linux webserver

    Or does it necessarily have to be?


    ISP Modem ---> linux webserver ---> local router (Linksys)

    Thanks

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    The first one works fine.
    Just make sure you forward your HTTP port in the router. And make sure your ISP allows you to have a Web server.
    Stand up and be counted as a Linux user!

  3. #3
    Just Joined! soccercisco's Avatar
    Join Date
    Dec 2006
    Location
    So. Cal
    Posts
    98
    Thanks (I was double-checking).

    The thing now is that when I try to access my ip address it goes directly into the ISP modem's configuration page (similar to the page where you can configure a router).

    how do I bypass this?

    Btw, I use earthlink's ADSL service (I'm not aware if they allow webservers, although mine is just to host a personal website [low-traffic]).

    Thanks again,

  4. #4
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Did you forward port 80 in the router (assuming Apache is running on port 80)?
    Stand up and be counted as a Linux user!

  5. #5
    Just Joined! soccercisco's Avatar
    Join Date
    Dec 2006
    Location
    So. Cal
    Posts
    98
    Thanks for the reply.

    Yep I forwarded port 80 on the router configuration.

    So now when I type my LAN IP address (for the webserver) in my web browser:

    192.168.5.50

    I see the standard startup page of Apache.

    I just cant get the internet IP address to point to the webserver.

    Btw, I also have the service zoneedit.com pointing my domain name to this ip address.

    The problem is how to bypass the ISP modem configuration website? That is, when I type the ip adress of my computer it takes me straight onto the modem (not the router) configuration website.

    Thanks,

  6. #6
    Just Joined! soccercisco's Avatar
    Join Date
    Dec 2006
    Location
    So. Cal
    Posts
    98

    To anyone with a webserver, please help.

    To anyone with a webserver, please help.

    Here's setup to aid me on my explanation. The | followed by a "v" indicates a down pointing arrow. I'm a newbie, so sorry if my terminology is off (although I've spent quite some time on linuxhomenetworking and other tutorials)

    Internet
    (WAN)
    |
    v
    (WAN)
    Modem Earthlink
    (LAN)
    |
    v
    Router Linksys
    (192.168.5.1)
    | ------------- |
    v ------------- v
    Web
    server ------- *This_PC*
    (192.168.5.50) (192.168.5.103)

    1) I went to my Linksys router setup page and forwarded port 80 to point at the Webserver's IP address (192.168.5.50)

    2) Now, from *This_PC* I can type on my web browser 192.168.5.50 and I can access the Webserver's startup page (apache's default page).

    3) My problem is getting access to the webserver from the WAN. If I type my WAN IP Address on a browser from *This_PC* I get to the Earthlink modem configuration page, which has no options of port forwarding.

    How can I point the WAN IP address to my webserver? I have tried forwarding port 8080 on the Linksys router to point at the Webserver's IP address (192.168.5.50) but this does not help.

    Thanks,

  7. #7
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    Oh, I see. That's going to depend on the modem. Does googling the model number turn up anything useful?
    Stand up and be counted as a Linux user!

  8. #8
    Just Joined! soccercisco's Avatar
    Join Date
    Dec 2006
    Location
    So. Cal
    Posts
    98
    I am trying right now to google it. I did not know what was the problem (I thought I was doing something wrong).

    My modem is (provided by Earthlink):
    Zyxel Prestige 600

    in the case somebody has done this before.

    Thanks,

  9. #9
    Just Joined! soccercisco's Avatar
    Join Date
    Dec 2006
    Location
    So. Cal
    Posts
    98
    This is exactly my problem:

    http://www.portforward.com/help/doub...forwarding.htm

    Everything on the LAN side works (I can see my webserver at both LAN levels) the probem is that l can't see it from the WAN side


    My first router is the ZyXEL Prestige 600 provided by the ISP (Earthlink)

    My second router (already configured) is a Linksys Wireless-G

    Thanks for you time and help,

  10. #10
    Just Joined! soccercisco's Avatar
    Join Date
    Dec 2006
    Location
    So. Cal
    Posts
    98

    Solution

    Thanks to all for trying to help.

    If anyone follows this:

    1) Go to the modems help tab.

    2) Click on advance settings.

    3) Disable PPoE.

    4) Configure your router to handle PPoE.

    For more details pm me.

    Cheers,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •