Find the answer to your Linux question:
Results 1 to 6 of 6
Hello all, I am currently running Fedora Core 6. So far I have gotten the dhcp running and got the port forwarding down using iptables. The only problem is the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7

    Internet Sharing Problems


    Hello all,
    I am currently running Fedora Core 6. So far I have gotten the dhcp running and got the port forwarding down using iptables. The only problem is the internet, on the network computers, will only work if I use ip addresses instead of domain names. So google.com does not work but http://72.14.207.99/ does. The internet work find on the server. I read that this may be a dns problem. Anyone know how to fix this one?

    Thank you

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,864
    The quickest fix is to set your DHCP information to provide the IP address of your ISP DNS server in its DNS field.

    Longer term, you probably want to set up a DNS server on your lan that allows you to assign names to the machines on the lan, and forwards all other requests on to your ISP's DNS server.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7
    Hello,
    How would I go about doing this? I am still a little new to linux. I got this far, so i really do not want to go back to firestarter. I have webmin install if that makes this any easier.

    thank you

  4. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,864
    Its in the DHCP settings somewhere. There must be a field that lets you specify the DNS server IP address to propogate. Take a look at the man page for the config file of your DHCP server, it must be in there somewhere. If you have already set up your DHCP system, then surely you know your way around its config file?
    Linux user #126863 - see http://linuxcounter.net/

  5. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7
    Quote Originally Posted by Roxoff
    Its in the DHCP settings somewhere. There must be a field that lets you specify the DNS server IP address to propogate. Take a look at the man page for the config file of your DHCP server, it must be in there somewhere. If you have already set up your DHCP system, then surely you know your way around its config file?
    I learned how to do a dhcp setup on one of my schools networks, but it was all computer to computer, so there was no need for a dns server. Here is my config file so far. Did I miss anything?

    Code:
    # DHCP Server Configuration file.
    #   see /usr/share/doc/dhcp*/dhcpd.conf.sample
    ddns-update-style interim;
    subnet 192.168.1.0 netmask 255.255.255.0 {
    
    # --- Default Gateway
            option routers                  192.168.1.1;
            option subnet-mask              255.255.255.0;
            option domain-name-servers 192.168.1.1;
            option domain-name-servers 10.0.0.2;
            option domain-name-servers 10.0.0.3;
            option time-offset              -18000;
    
            range 192.168.1.100 192.168.1.250;
    
            default-lease-time 21600;
            max-lease-time 43200;
    }

  6. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,864
    I know absolutely zero about DHCP, but looking at that file, I'd suggest you change the line that reads 'option domain-name-servers ...' to the IP address given you by your ISP for their DNS server. You should also remove the other 'option-domain-name-servers ...' lines, then restart DHCP. When you restart the networking service on the DHCP machines (or reboot them if they're not Linux machines) then it should all work nicely.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •