hi,
i am using openvpn 2.1_rc1.
i have successfully installed openvpn on client (windows xp sp2) and server(on

linux) . i am able to complete authentication process,it completes

successfully.then it shows connection initialization successful.

then both client (windows xp) and server (linux ) are not able to ping each

other.server even block netwirk traffic so no one is able to ping it.

windows having ip address 192.168.0.22
linux having ip address 192.168.0.5
i have dissabled firewall at both the sides.

here are logs and conf files.

server.conf
##################################################
local 192.168.0.5
port 1194
proto tcp
dev tun
ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
server 192.68.0.0 255.255.255.0
keepalive 10 120
comp-lzo
max-clients 100
user nobody
group nobody
persist-key
persist-tun
status open.log
log op.log
log-append op.log
ver 3
################################################3

client.conf
##################################################
client

dev tun
proto tcp
remote 192.168.0.5 1194
resolv-retry infinite
nobind

persist-key
persist-tun
ca "C:\\Program Files\\OpenVPN2.1\\easy-rsa\\keys\\ca.crt"
cert "C:\\Program Files\\OpenVPN2.1\\easy-rsa\\keys\\client22.crt"
key "C:\\Program Files\\OpenVPN2.1\\easy-rsa\\keys\\client22.key"

ns-cert-type server


comp-lzo


verb 3

################################################## ############################



client log file
################################################## ############################

Wed Feb 14 13:15:52 2007 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct 1

2006
Wed Feb 14 13:15:52 2007 IMPORTANT: OpenVPN's default port number is now 1194,

based on an official port number assignment by IANA. OpenVPN 2.0-beta16 and

earlier used 5000 as the default port.
Wed Feb 14 13:15:52 2007 LZO compression initialized
Wed Feb 14 13:15:52 2007 Control Channel MTU parms [ L:1544 D:140 EF:40 EB:0

ET:0 EL:0 ]
Wed Feb 14 13:15:52 2007 Data Channel MTU parms [ L:1544 D:1450 EF:44 EB:135

ET:0 EL:0 AF:3/1 ]
Wed Feb 14 13:15:52 2007 Local Options hash (VER=V4): '69109d17'
Wed Feb 14 13:15:52 2007 Expected Remote Options hash (VER=V4): 'c0103fa8'
Wed Feb 14 13:15:52 2007 Attempting to establish TCP connection with

192.168.0.5:1194
Wed Feb 14 13:15:52 2007 TCP connection established with 192.168.0.5:1194
Wed Feb 14 13:15:52 2007 TCPv4_CLIENT link local: [undef]
Wed Feb 14 13:15:52 2007 TCPv4_CLIENT link remote: 192.168.0.5:1194
Wed Feb 14 13:15:52 2007 TLS: Initial packet from 192.168.0.5:1194,

sid=cf2676a4 bbb000b9
Wed Feb 14 13:15:53 2007 VERIFY OK: depth=1,

/C=in/ST=gujarat/L=baroda/O=bullwark/OU=vpn/CN=host5/emailAddress=me@myhost.my

domain
Wed Feb 14 13:15:53 2007 VERIFY OK: nsCertType=SERVER
Wed Feb 14 13:15:53 2007 VERIFY OK: depth=0,

/C=in/ST=gujarat/L=baroda/O=bulwark/OU=vpn/CN=server/emailAddress=me@myhost.my

domain
Wed Feb 14 13:15:54 2007 Data Channel Encrypt: Cipher 'BF-CBC' initialized

with 128 bit key
Wed Feb 14 13:15:54 2007 Data Channel Encrypt: Using 160 bit message hash

'SHA1' for HMAC authentication
Wed Feb 14 13:15:54 2007 Data Channel Decrypt: Cipher 'BF-CBC' initialized

with 128 bit key
Wed Feb 14 13:15:54 2007 Data Channel Decrypt: Using 160 bit message hash

'SHA1' for HMAC authentication
Wed Feb 14 13:15:54 2007 Control Channel: TLSv1, cipher TLSv1/SSLv3

DHE-RSA-AES256-SHA, 1024 bit RSA
Wed Feb 14 13:15:54 2007 [server] Peer Connection Initiated with

192.168.0.5:1194
Wed Feb 14 13:15:54 2007 SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
Wed Feb 14 13:15:55 2007 PUSH: Received control message: 'PUSH_REPLY,route

192.168.0.1,topology net30,ping 10,ping-restart 120,ifconfig 192.168.0.6

192.168.0.5'
Wed Feb 14 13:15:55 2007 Options error: Unrecognized option or missing

parameter(s) in [PUSH-OPTIONS]:2: topology (2.0.9)
Wed Feb 14 13:15:55 2007 OPTIONS IMPORT: timers and/or timeouts modified
Wed Feb 14 13:15:55 2007 OPTIONS IMPORT: --ifconfig/up options modified
Wed Feb 14 13:15:55 2007 OPTIONS IMPORT: route options modified
Wed Feb 14 13:15:55 2007 WARNING: --remote address [192.168.0.5] conflicts

with --ifconfig address pair [192.168.0.6, 192.168.0.5]. (silence this warning

with --ifconfig-nowarn)
Wed Feb 14 13:15:55 2007 WARNING: potential conflict between --remote address

[192.168.0.5] and --ifconfig address pair [192.168.0.6, 192.168.0.5] -- this

is a warning only that is triggered when local/remote addresses exist within

the same /24 subnet as --ifconfig endpoints. (silence this warning with

--ifconfig-nowarn)
Wed Feb 14 13:15:55 2007 TAP-WIN32 device [Local Area Connection 3] opened:

\\.\Global\{07408D71-15F2-494B-AC3F-6805C3EA56C2}.tap
Wed Feb 14 13:15:55 2007 TAP-Win32 Driver Version 8.4
Wed Feb 14 13:15:55 2007 TAP-Win32 MTU=1500
Wed Feb 14 13:15:55 2007 Notified TAP-Win32 driver to set a DHCP IP/netmask of

192.168.0.6/255.255.255.252 on interface

{07408D71-15F2-494B-AC3F-6805C3EA56C2} [DHCP-serv: 192.168.0.5, lease-time:

31536000]
Wed Feb 14 13:15:55 2007 Successful ARP Flush on interface [3]

{07408D71-15F2-494B-AC3F-6805C3EA56C2}
Wed Feb 14 13:15:55 2007 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Feb 14 13:15:55 2007 Route: Waiting for TUN/TAP interface to come up...
Wed Feb 14 13:15:56 2007 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Feb 14 13:15:56 2007 Route: Waiting for TUN/TAP interface to come up...
Wed Feb 14 13:15:57 2007 TEST ROUTES: 0/0 succeeded len=1 ret=0 a=0 u/d=down
Wed Feb 14 13:15:57 2007 Route: Waiting for TUN/TAP interface to come up...
Wed Feb 14 13:15:58 2007 TEST ROUTES: 1/1 succeeded len=1 ret=1 a=0 u/d=up
Wed Feb 14 13:15:58 2007 route ADD 192.168.0.1 MASK 255.255.255.255

192.168.0.5
Wed Feb 14 13:15:58 2007 Route addition via IPAPI succeeded
Wed Feb 14 13:15:58 2007 Initialization Sequence Completed
------------------


after this it hangs,
both sides cant ping each other

if any one have any idea then reply.

-thanks