Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Mounting Windows drives at boot - Sorted

    I have sucessfully mounted a windows drive using the following command:

    mount -t smbfs //Server/Share -o username='User name',password=password,fmask=777,dmask=777 /media/share/
    This allows write access etc, but i am trying to get it to automount at boot. i have added the following line to the /etc/fstab:
    //Server/Share    /media/share             smbfs      username='User Name',password=password,fmask=777,dmask=777 0 0
    i have put the password in single quotes as it has 2 words in it. Now the error i get when i run
    mount -a

    [mntent]: line 22 in /etc/fstab is bad
    mount: wrong fs type, bad option, bad superblock on /dev/hda3,
           or too many mounted file systems
           (aren't you trying to mount an extended partition,
           instead of some logical partition inside?)
    Can anyone help me with this? The server is running Win 2K. I have also got a Linux box with smb shares, and these successfully mount with the same fstab line, but modifies for the relevant pc etc.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  2. #2
    Have sorted this out now.... i needed a username on the windows computer that was one word long. but apart from that the rest of the /etc/fstab is fine as in my other post.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts