Find the answer to your Linux question:
Results 1 to 3 of 3
Hey there, i'm new in here so greetings all! The issue i'm trying to figure out is how to disable passive mode and activate active mode when i'm trying to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    2

    Firewall, Nat, Ftp


    Hey there, i'm new in here so greetings all!
    The issue i'm trying to figure out is how to disable passive mode and activate active mode when i'm trying to connect to a ftp. If i make a ftp connection to a local server active mode works fine but when i try to establish an external connection it dies ( 500 illegal port command), i have to enable passive mode for it to work. I suppose my firewall or NAT has something to do with this. Any ideeas on how to enable active mode??
    Thanks alot,

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    Frederick, MD, USA
    Posts
    93

    Which ftp client are you using?

    I use ncftp. It appears to be smart enough to switch to passive mode when active mode does not work. After you start ncftp you can issue a command to choose active or passive mode.
    Code:
    set passive on 
    set passive off
    set passive auto
    When I use auto it takes longer to connect to external ftp servers, but it does eventually work. When I use passive the connection comes up faster.

  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    2
    Thanks for the tip. I'll try ncftp too, but first i'd like to solve this problem because it exists since i' ve migrated from redhat to fedora. I set up firewall and ipchains and run into this problem. Perhaps i missed something but still ports 20, 21 are oppened for ftp but cannot set it up to work only in active mode. Something's fishy there
    Thanks again,

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •