Find the answer to your Linux question:
Results 1 to 3 of 3
So I finally accepted the truth that I couldn't get my winmodem working under Ubuntu; so I bit the bullet and scored a cheap serial modem off of TradeMe (New ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    2

    Linux can't access Serial Modem


    So I finally accepted the truth that I couldn't get my winmodem working under Ubuntu; so I bit the bullet and scored a cheap serial modem off of TradeMe (New Zealand auction site). It's an Elsa MicroLink 56k Fun Modem, connected by a 9-pin serial plug.

    However, wvdialconf can't see it, and if I try to dial out using /dev/ttyS0 (I'm pretty sure it's the right one) it can't initialize it. I can't find any init strings on the net, but I did see I forum posting where a person said they'd bought this modem as a last resort for Linux dial up, and it had worked no problem, no fiddling.

    It doesn't work under the Windows' default drivers either, but I'm 95% sure that the cable is a working one for modems, and that the modem is working.

    I have tried two serial modems, and neither have worked under Windows or under Linux. However, I'm really sure that both modems are working modems, and both cables are working cables; could it be a problem with a serial port?

    I am at my wits end; I just want to connect Ubuntu to the internet so I can finally get rid of this Windows partition, but I'm not having much luck. Can any kind person help?

    I'm running Ubuntu 6.10, kernel 2.6.17-10 (x86)

    Cheers,
    -Bernard.

  2. #2
    Just Joined!
    Join Date
    Jul 2007
    Posts
    2
    Try using minicom to access modem in ubuntu..

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    2
    Hi Bhelyer
    Open minicom and configure it with appropriate settings like Baudrate,parity etc.
    Just short TX/RX pins(p2 and p3 pins) on the serial DB cable and cross verify on the terminal.
    You can do the same in windows using hyperterminal software.


    Regards
    Harshad Kulkarni

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •